aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi')
-rw-r--r--target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi241
1 files changed, 0 insertions, 241 deletions
diff --git a/target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi b/target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi
deleted file mode 100644
index 558a763747..0000000000
--- a/target/linux/ath79/dts/ar9344_tl-wdr4300.dtsi
+++ /dev/null
@@ -1,241 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9344.dtsi"
-
-/ {
- model = "TP-Link WDR4300";
- compatible = "tplink,tl-wdr4300";
-
- aliases {
- led-status = &system;
- };
-
- leds {
- compatible = "gpio-leds";
-
- usb1 {
- label = "tp-link:green:usb1";
- gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
- default-state = "off";
- trigger-sources = <&hub_port1>;
- linux,default-trigger = "usbport";
- };
-
- usb2 {
- label = "tp-link:green:usb2";
- gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
- default-state = "off";
- trigger-sources = <&hub_port2>;
- linux,default-trigger = "usbport";
- };
-
- wlan2g {
- label = "tp-link:green:wlan2g";
- gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy0tpt";
- };
-
- system: system {
- label = "tp-link:green:system";
- gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
- default-state = "on";
- };
-
- qss {
- label = "tp-link:green:qss";
- gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
- };
-
- ath9k-leds {
- compatible = "gpio-leds";
-
- wlan5g {
- label = "tp-link:green:wlan5g";
- gpios = <&ath9k 0 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy1tpt";
- };
- };
-
- keys {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset {
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- wifi {
- linux,code = <KEY_RFKILL>;
- linux,input-type = <EV_SW>;
- gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-
- gpio-export {
- compatible = "gpio-export";
- #size-cells = <0>;
-
- gpio_usb1_power {
- gpio-export,name = "tp-link:power:usb1";
- gpio-export,output = <1>;
- gpios = <&gpio 22 GPIO_ACTIVE_HIGH>;
- };
-
- gpio_usb2_power {
- gpio-export,name = "tp-link:power:usb2";
- gpio-export,output = <1>;
- gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
- };
-
- gpio_ext_lna0 {
- gpio-export,name = "tp-link:ext:lna0";
- gpio-export,output = <1>;
- gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
- };
-
- gpio_ext_lna1 {
- gpio-export,name = "tp-link:ext:lna1";
- gpio-export,output = <1>;
- gpios = <&gpio 19 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&ref {
- clock-frequency = <40000000>;
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&spi {
- num-cs = <1>;
-
- status = "okay";
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- uboot: partition@0 {
- label = "u-boot";
- reg = <0x000000 0x020000>;
- read-only;
- };
-
- partition@20000 {
- label = "firmware";
- reg = <0x020000 0x7d0000>;
- };
-
- art: partition@7f0000 {
- label = "art";
- reg = <0x7f0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-&usb {
- status = "okay";
-
- port@1 {
- reg = <1>;
- #trigger-source-cells = <0>;
-
- hub_port1: port@1 {
- reg = <1>;
- #trigger-source-cells = <0>;
- };
-
- hub_port2: port@2 {
- reg = <2>;
- #trigger-source-cells = <0>;
- };
- };
-};
-
-&usb_phy {
- status = "okay";
-};
-
-&pcie {
- status = "okay";
-
- ath9k: wifi@168c,0033 {
- compatible = "pci168c,0033";
- reg = <0x0000 0 0 0 0>;
- mtd-mac-address = <&uboot 0x1fc00>;
- qca,no-eeprom;
- #gpio-cells = <2>;
- gpio-controller;
- };
-};
-
-&wmac {
- status = "okay";
-
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&uboot 0x1fc00>;
- mtd-mac-address-increment = <(-1)>;
-};
-
-&mdio0 {
- status = "okay";
-
- phy-mask = <0>;
-
- phy0: ethernet-phy@0 {
- reg = <0>;
- phy-mode = "rgmii";
-
- qca,ar8327-initvals = <
- 0x04 0x07600000 /* PORT0 PAD MODE CTRL */
- 0x10 0x80000080 /* POWER_ON_STRIP */
- 0x50 0xc737c737 /* LED_CTRL0 */
- 0x54 0x00000000 /* LED_CTRL1 */
- 0x58 0x00000000 /* LED_CTRL2 */
- 0x5c 0x0030c300 /* LED_CTRL3 */
- 0x7c 0x0000007e /* PORT0_STATUS */
- >;
- };
-};
-
-&eth0 {
- status = "okay";
-
- /* default for ar934x, except for 1000M */
- pll-data = <0x06000000 0x00000101 0x00001616>;
-
- mtd-mac-address = <&uboot 0x1fc00>;
- mtd-mac-address-increment = <(-2)>;
-
- phy-mode = "rgmii";
- phy-handle = <&phy0>;
-};