aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar9331_omega.dts
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar9331_omega.dts
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar9331_omega.dts')
-rw-r--r--target/linux/ath79/dts/ar9331_omega.dts74
1 files changed, 0 insertions, 74 deletions
diff --git a/target/linux/ath79/dts/ar9331_omega.dts b/target/linux/ath79/dts/ar9331_omega.dts
deleted file mode 100644
index cc47f56e84..0000000000
--- a/target/linux/ath79/dts/ar9331_omega.dts
+++ /dev/null
@@ -1,74 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9331.dtsi"
-
-/ {
- model = "Onion Omega";
- compatible = "onion,omega", "qca,ar9331";
-
- aliases {
- serial0 = &uart;
- };
-
- leds {
- compatible = "gpio-leds";
-
- system {
- label = "onion:amber:system";
- gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
- };
-
- keys {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <100>;
-
- button@0 {
- label = "reset";
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&ref {
- clock-frequency = <25000000>;
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&usb {
- dr_mode = "host";
- status = "okay";
-};
-
-&usb_phy {
- status = "okay";
-};
-
-&spi {
- num-chipselects = <1>;
- status = "okay";
-
- /* Winbond 25Q128FVSG SPI flash */
- spiflash: w25q128@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "winbond,w25q128", "jedec,spi-nor";
- spi-max-frequency = <104000000>;
- reg = <0>;
- };
-};