aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar9331_etactica-eg200.dts
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar9331_etactica-eg200.dts
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar9331_etactica-eg200.dts')
-rw-r--r--target/linux/ath79/dts/ar9331_etactica-eg200.dts134
1 files changed, 0 insertions, 134 deletions
diff --git a/target/linux/ath79/dts/ar9331_etactica-eg200.dts b/target/linux/ath79/dts/ar9331_etactica-eg200.dts
deleted file mode 100644
index 5d6b72cd80..0000000000
--- a/target/linux/ath79/dts/ar9331_etactica-eg200.dts
+++ /dev/null
@@ -1,134 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9331.dtsi"
-
-/ {
- model = "eTactica EG200";
- compatible = "etactica,eg200", "rme-eg200";
-
- aliases {
- serial0 = &uart;
- };
-
- keys {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <50>;
-
- restore {
- linux,code = <KEY_WPS_BUTTON>;
- gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- modbus {
- label = "eg200:red:modbus";
- gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
- default-state = "off";
- };
-
- etactica {
- label = "eg200:red:etactica";
- gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
- default-state = "off";
- };
-
- eth0 {
- label = "eg200:red:eth0";
- gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
- default-state = "off";
- };
-
- wlan {
- label = "eg200:red:wlan";
- gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy0tpt";
- };
- };
-};
-
-&uart {
- status = "okay";
-};
-
-&gpio {
- status = "okay";
-};
-
-&usb {
- dr_mode = "host";
- status = "okay";
-};
-
-&usb_phy {
- status = "okay";
-};
-
-&eth0 {
- status = "okay";
- mtd-mac-address = <&art 0x0>;
-
- gmac-config {
- device = <&gmac>;
- switch-phy-addr-swap = <1>;
- switch-phy-swap = <1>;
- };
-};
-
-&eth1 {
- status = "okay";
- compatible = "syscon", "simple-mfd";
-};
-
-&spi {
- num-chipselects = <1>;
- status = "okay";
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- spi-max-frequency = <50000000>;
- reg = <0>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- uboot@0 {
- reg = <0x0 0x40000>;
- read-only;
- };
-
- uboot-env@40000 {
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- firmware@50000 {
- reg = <0x50000 0xfa0000>;
- };
-
- art: art@ff0000 {
- reg = <0xff0000 0x10000>;
- read-only;
- };
- };
- };
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&art 0x1002>;
-};