aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts')
-rw-r--r--target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts158
1 files changed, 0 insertions, 158 deletions
diff --git a/target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts b/target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts
deleted file mode 100644
index d01d2cc716..0000000000
--- a/target/linux/ath79/dts/ar9132_tl-wr1043nd-v1.dts
+++ /dev/null
@@ -1,158 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9132.dtsi"
-
-/ {
- compatible = "tplink,tl-wr1043nd-v1", "qca,ar9132";
- model = "TP-Link TL-WR1043ND Version 1";
-
- aliases {
- led-status = &system;
- };
-
- extosc: ref {
- compatible = "fixed-clock";
- #clock-cells = <0>;
- clock-frequency = <40000000>;
- };
-
- keys {
- compatible = "gpio-keys";
- #address-cells = <1>;
- #size-cells = <0>;
-
- button0 {
- label = "reset";
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- button1 {
- label = "qss";
- linux,code = <KEY_WPS_BUTTON>;
- gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
- usb {
- label = "tp-link:green:usb";
- gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
- default-state = "off";
- trigger-sources = <&hub_port>;
- linux,default-trigger = "usbport";
- };
-
- system: system {
- label = "tp-link:green:system";
- gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "heartbeat";
- };
-
- qss {
- label = "tp-link:green:qss";
- gpios = <&gpio 5 GPIO_ACTIVE_HIGH>;
- };
-
- wlan {
- label = "tp-link:green:wlan";
- gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
- default-state = "off";
- linux,default-trigger = "phy0tpt";
- };
- };
-
- rtl8366rb {
- compatible = "realtek,rtl8366rb";
- gpio-sda = <&gpio 18 GPIO_ACTIVE_HIGH>;
- gpio-sck = <&gpio 19 GPIO_ACTIVE_HIGH>;
-
- resets = <&rst 8>;
- reset-names = "switch";
- };
-};
-
-&uart {
- status = "okay";
-};
-
-&pll {
- clocks = <&extosc>;
-};
-
-&usb {
- status = "okay";
-
- hub_port: port@1 {
- reg = <1>;
- #trigger-source-cells = <0>;
- };
-};
-
-&usb_phy {
- status = "okay";
-};
-
-&spi {
- status = "okay";
- num-cs = <1>;
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- uboot: partition@0 {
- label = "u-boot";
- reg = <0x000000 0x020000>;
- read-only;
- };
-
- partition@20000 {
- label = "firmware";
- reg = <0x020000 0x7D0000>;
- };
-
- art: partition@7F0000 {
- label = "art";
- reg = <0x7F0000 0x010000>;
- read-only;
- };
- };
- };
-};
-
-&eth0 {
- status = "okay";
-
- phy-mode = "rgmii";
- mtd-mac-address = <&uboot 0x1fc00>;
-
- resets = <&rst 9>;
- reset-names = "mac";
-
- fixed-link {
- speed = <1000>;
- full-duplex;
- };
-};
-
-&wmac {
- status = "okay";
- mtd-cal-data = <&art 0x1000>;
- mtd-mac-address = <&uboot 0x1fc00>;
-};