aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar7241_tp-link.dtsi
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar7241_tp-link.dtsi
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar7241_tp-link.dtsi')
-rw-r--r--target/linux/ath79/dts/ar7241_tp-link.dtsi117
1 files changed, 0 insertions, 117 deletions
diff --git a/target/linux/ath79/dts/ar7241_tp-link.dtsi b/target/linux/ath79/dts/ar7241_tp-link.dtsi
deleted file mode 100644
index 6cc515b7cc..0000000000
--- a/target/linux/ath79/dts/ar7241_tp-link.dtsi
+++ /dev/null
@@ -1,117 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar7241.dtsi"
-
-/ {
- aliases {
- led-status = &led_system;
- };
-
- gpio-keys-polled {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset {
- label = "reset";
- linux,code = <KEY_RESTART>;
- gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
-
- qss {
- label = "qss";
- linux,code = <KEY_WPS_BUTTON>;
- gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- };
- };
-
- gpio_leds: gpio-leds {
- compatible = "gpio-leds";
-
- led_system: system {
- label = "tp-link:green:system";
- gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
- };
-
- qss {
- label = "tp-link:green:qss";
- gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
- };
- };
-};
-
-&spi {
- status = "okay";
- num-cs = <1>;
-
- flash@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- uboot: partition@0 {
- reg = <0x0 0x20000>;
- label = "u-boot";
- read-only;
- };
-
- partition@20000 {
- reg = <0x20000 0x3d0000>;
- label = "firmware";
- };
-
- partition@3f0000 {
- reg = <0x3f0000 0x10000>;
- label = "art";
- read-only;
- };
- };
- };
-};
-
-&pcie {
- status = "okay";
-
- ath9k: wifi@0 {
- reg = <0x0000 0 0 0 0>;
- #gpio-cells = <2>;
- gpio-controller;
- qca,no-eeprom;
- mtd-mac-address = <&uboot 0x1fc00>;
- };
-};
-
-&eth0 {
- status = "okay";
-
- mtd-mac-address = <&uboot 0x1fc00>;
- mtd-mac-address-increment = <(-1)>;
-};
-
-&eth1 {
- status = "okay";
-
- mtd-mac-address = <&uboot 0x1fc00>;
- mtd-mac-address-increment = <1>;
-};
-
-&gpio {
- status = "okay";
-};
-
-&uart {
- status = "okay";
-};