aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/Makefile
diff options
context:
space:
mode:
authorSergey Ryazanov <ryazanov.s.a@gmail.com>2021-12-19 17:31:53 +0300
committerDaniel Golle <daniel@makrotopia.org>2021-12-27 16:00:21 +0000
commit5deb3996e249e15bb5711695c917641a1490670a (patch)
tree43582de46d470d5e9e064b4b4a8b3aa49d873955 /target/linux/ath25/Makefile
parent5bf8ae7c4bd2e1fc216a6af81ab931e1b0861271 (diff)
downloadupstream-5deb3996e249e15bb5711695c917641a1490670a.tar.gz
upstream-5deb3996e249e15bb5711695c917641a1490670a.tar.bz2
upstream-5deb3996e249e15bb5711695c917641a1490670a.zip
ath25: add kernel 5.10 support
Copy and refresh patches and config from 5.4 to 5.10. Most patches require no more then automatic refresh. The only exception is the Ethernet driver patch, which requires some more work: * drop eth_change_mtu() usage since it was removed from the kernel, it anyway useless for drivers that utilizes alloc_etherdev(); * add the txqueue number argument to the .ndo_tx_timeout callback function; * replace ioremap_nocache() which was finally removed from the kernel by the ioremap() with the same behaviour. Switch target to the new kernel version. Signed-off-by: Daniel Golle <daniel@makrotopia.org> [use KERNEL_TESTING_PATCHVER for now] Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com>
Diffstat (limited to 'target/linux/ath25/Makefile')
-rw-r--r--target/linux/ath25/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ath25/Makefile b/target/linux/ath25/Makefile
index 1d8bee507b..c714edeaaa 100644
--- a/target/linux/ath25/Makefile
+++ b/target/linux/ath25/Makefile
@@ -10,6 +10,7 @@ BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs low_mem small_flash
KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.10
define Target/Description
Build firmware images for Atheros SoC boards