aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-01-26 16:04:54 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-30 23:14:45 +0100
commitf938512af63916ed3b131f647e84aafadfa332fc (patch)
tree66cce57654276057db6f83fabff0cca6e6b2eaca /target/linux/at91
parent1dccc6e74984e62f1e4cde70028bd422dbc37979 (diff)
downloadupstream-f938512af63916ed3b131f647e84aafadfa332fc.tar.gz
upstream-f938512af63916ed3b131f647e84aafadfa332fc.tar.bz2
upstream-f938512af63916ed3b131f647e84aafadfa332fc.zip
target/at91: replace gpio-mcp23s08 with pinctrl-mcp23s08-spi update config
Adapt the device package to no longer use the gpio-mcp23s08 but instead use the pinctrl-mcp23s08-spi. In addition, the kernel configuration was adapted so that this can be built as a module and does not have to be integrated directly into the kernel for this target. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/sam9x.mk3
-rw-r--r--target/linux/at91/sam9x/config-5.104
-rw-r--r--target/linux/at91/sam9x/config-5.154
3 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/at91/image/sam9x.mk b/target/linux/at91/image/sam9x.mk
index b6c5e33ac4..4de9609775 100644
--- a/target/linux/at91/image/sam9x.mk
+++ b/target/linux/at91/image/sam9x.mk
@@ -126,7 +126,8 @@ define Device/calamp_lmu5000
DEVICE_VENDOR := CalAmp
DEVICE_MODEL := LMU5000
DEVICE_PACKAGES := kmod-rtc-pcf2123 kmod-usb-acm \
- kmod-usb-serial-option kmod-usb-serial-sierrawireless kmod-gpio-mcp23s08
+ kmod-usb-serial-option kmod-usb-serial-sierrawireless \
+ kmod-pinctrl-mcp23s08-spi
endef
TARGET_DEVICES += calamp_lmu5000
diff --git a/target/linux/at91/sam9x/config-5.10 b/target/linux/at91/sam9x/config-5.10
index 63575c6093..da2229b22a 100644
--- a/target/linux/at91/sam9x/config-5.10
+++ b/target/linux/at91/sam9x/config-5.10
@@ -217,9 +217,7 @@ CONFIG_PHYLINK=y
CONFIG_PINCTRL=y
CONFIG_PINCTRL_AT91=y
# CONFIG_PINCTRL_AT91PIO4 is not set
-CONFIG_PINCTRL_MCP23S08=y
-CONFIG_PINCTRL_MCP23S08_I2C=y
-CONFIG_PINCTRL_MCP23S08_SPI=y
+# CONFIG_PINCTRL_MCP23S08 is not set
CONFIG_PM=y
CONFIG_PM_CLK=y
CONFIG_PM_SLEEP=y
diff --git a/target/linux/at91/sam9x/config-5.15 b/target/linux/at91/sam9x/config-5.15
index ffbd2aba62..85fe1dd8af 100644
--- a/target/linux/at91/sam9x/config-5.15
+++ b/target/linux/at91/sam9x/config-5.15
@@ -219,9 +219,7 @@ CONFIG_PHYLINK=y
CONFIG_PINCTRL=y
CONFIG_PINCTRL_AT91=y
# CONFIG_PINCTRL_AT91PIO4 is not set
-CONFIG_PINCTRL_MCP23S08=y
-CONFIG_PINCTRL_MCP23S08_I2C=y
-CONFIG_PINCTRL_MCP23S08_SPI=y
+# CONFIG_PINCTRL_MCP23S08 is not set
CONFIG_PM=y
CONFIG_PM_CLK=y
CONFIG_PM_SLEEP=y