aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:18 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:01:09 +0200
commit09bf44109043811eba45e2113307be23cb45ea8a (patch)
treee3f4f3261cfe95f6430ca36f552df5ee8ff1ce55 /target/linux/at91
parent67303259ee234a4db5d611fdba1f8596e3a7b8b6 (diff)
downloadupstream-09bf44109043811eba45e2113307be23cb45ea8a.tar.gz
upstream-09bf44109043811eba45e2113307be23cb45ea8a.tar.bz2
upstream-09bf44109043811eba45e2113307be23cb45ea8a.zip
at91: Add UBI parameters for sama5d4.
Add UBIFS_OPTS & UBINIZE_OPTS parameters for sama5d4 Xplained board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 99c7e21669..93337097c0 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,7 +16,12 @@ endif
ifeq ($(SUBTARGET),sama5)
include ./sama5.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+ifeq ($(TARGET_DEVICES),at91-sama5d4_xplained)
+ UBIFS_OPTS := -e 0x3e000 -c 2082 -m 0x1000 -x lzo
+ UBINIZE_OPTS := -m 0x1000 -p 0x40000
+else
+ UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+endif
endif
define Device/Default