aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-10-16 21:36:17 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-16 23:05:54 +0200
commit61048c901189d3d24ffc35e2e0ab2355f6ec0dbc (patch)
tree736afa6024ba9695dc20cabfe88e447f738eb363 /target/linux/at91
parenta29848c67180396656e4e8a7ef47ae5b441a7325 (diff)
downloadupstream-61048c901189d3d24ffc35e2e0ab2355f6ec0dbc.tar.gz
upstream-61048c901189d3d24ffc35e2e0ab2355f6ec0dbc.tar.bz2
upstream-61048c901189d3d24ffc35e2e0ab2355f6ec0dbc.zip
at91: fix legacy build
The build system took the DTB_SIZE definition from Default and not from production-dtb under some conditions. Move the size definitions to Default now as it is only used in production-dtb anyway. Thanks Mathias Kresin for helping me with this. Fixes: c2f052acaeb ("at91: convert boards to generic build target") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index fedefe4287..12607073e4 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -24,7 +24,7 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL_SIZE := 4096k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
- DTB_SIZE :=
+ DTB_SIZE := 128k
endef
define Device/dtb
@@ -66,7 +66,6 @@ endef
define Device/production-dtb
$(Device/production)
$(Device/dtb)
- DTB_SIZE := 128k
IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
| append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef