aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2017-06-01 23:04:52 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:21 +0200
commita7c8112a0ff609e85bfd58e21efec6322f946285 (patch)
tree79ac9e6f42b3b85ffa62c61275966df6a655e032 /target/linux/at91
parent3b6f9978d32e3922cfd68c811a9b0f41997743bf (diff)
downloadupstream-a7c8112a0ff609e85bfd58e21efec6322f946285.tar.gz
upstream-a7c8112a0ff609e85bfd58e21efec6322f946285.tar.bz2
upstream-a7c8112a0ff609e85bfd58e21efec6322f946285.zip
at91: separate MKUBIFS opts to defaults in the sub target
Instead of applying global defaults based on selected board, transition to using a per board setting for UBIFS and UBINIZE. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile12
-rw-r--r--target/linux/at91/image/legacy.mk7
-rw-r--r--target/linux/at91/image/sama5.mk12
3 files changed, 18 insertions, 13 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 93337097c0..db480ac754 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -11,29 +11,19 @@ KERNEL_LOADADDR := 0x20008000
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
-UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
endif
-
ifeq ($(SUBTARGET),sama5)
include ./sama5.mk
-ifeq ($(TARGET_DEVICES),at91-sama5d4_xplained)
- UBIFS_OPTS := -e 0x3e000 -c 2082 -m 0x1000 -x lzo
- UBINIZE_OPTS := -m 0x1000 -p 0x40000
-else
- UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
-endif
endif
define Device/Default
+ $(Device/default-nand)
PROFILES := Default
FILESYSTEMS := squashfs ubifs
DEVICE_DTS := $(1)
KERNEL_NAME := zImage
KERNEL_SIZE := 4096k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 512
DTB_SIZE :=
endef
diff --git a/target/linux/at91/image/legacy.mk b/target/linux/at91/image/legacy.mk
index 7fe388135d..be8c2db21c 100644
--- a/target/linux/at91/image/legacy.mk
+++ b/target/linux/at91/image/legacy.mk
@@ -1,3 +1,10 @@
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 126KiB -c 2048
+endef
+
define Device/at91sam9263ek
$(Device/evaluation-dtb)
DEVICE_TITLE := Atmel AT91SAM9263-EK
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 580b51e98f..1c779ca327 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -1,8 +1,14 @@
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
define Device/at91-sama5d3_xplained
$(Device/evaluation-dtb)
DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
KERNEL_SIZE := 6144k
- SUBPAGESIZE := 2048
endef
TARGET_DEVICES += at91-sama5d3_xplained
@@ -10,7 +16,6 @@ define Device/at91-sama5d2_xplained
$(Device/evaluation-dtb)
DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
KERNEL_SIZE := 6144k
- SUBPAGESIZE := 2048
endef
TARGET_DEVICES += at91-sama5d2_xplained
@@ -18,6 +23,9 @@ define Device/at91-sama5d4_xplained
$(Device/evaluation-dtb)
DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
KERNEL_SIZE := 6144k
+ BLOCKSIZE := 256k
+ PAGESIZE := 4096
SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
endef
TARGET_DEVICES += at91-sama5d4_xplained