aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/legacy
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2017-05-03 22:15:20 +0100
committerMathias Kresin <dev@kresin.me>2017-06-12 21:07:31 +0200
commitc2f052acaeb480e89d3ce39c47f49ad16b3464ac (patch)
treec9c0120592edc98f86d438704131d25acc4a1147 /target/linux/at91/legacy
parenta53f8ba6771de64c9c82a2e6867791226f3003cb (diff)
downloadupstream-c2f052acaeb480e89d3ce39c47f49ad16b3464ac.tar.gz
upstream-c2f052acaeb480e89d3ce39c47f49ad16b3464ac.tar.bz2
upstream-c2f052acaeb480e89d3ce39c47f49ad16b3464ac.zip
at91: convert boards to generic build target
Evaluation boards are left in component form to ease flashing using vendor tooling and instructions. These boards also do not include the EOF marker in the UBIFS as the bootloaders are recent and easily upgradeable. The end product boards use factory.bin images based on the dts layout and include EOF markers as bootloader UBI support is not determined. Signed-off-by: Ben Whitten <ben.whitten@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/at91/legacy')
-rw-r--r--target/linux/at91/legacy/profiles/00-default.mk16
-rw-r--r--target/linux/at91/legacy/profiles/atmel.mk86
-rw-r--r--target/linux/at91/legacy/profiles/calamp.mk23
3 files changed, 0 insertions, 125 deletions
diff --git a/target/linux/at91/legacy/profiles/00-default.mk b/target/linux/at91/legacy/profiles/00-default.mk
deleted file mode 100644
index 3ff040d2e4..0000000000
--- a/target/linux/at91/legacy/profiles/00-default.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
- NAME:=Default Profile
-endef
-
-define Profile/Default/Description
- Default package set compatible with most boards.
-endef
-
-$(eval $(call Profile,Default))
diff --git a/target/linux/at91/legacy/profiles/atmel.mk b/target/linux/at91/legacy/profiles/atmel.mk
deleted file mode 100644
index 4b14f939ee..0000000000
--- a/target/linux/at91/legacy/profiles/atmel.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/AT91SAM9263EK
- NAME:=Atmel AT91SAM9263-EK
-endef
-define Profile/AT91SAM9263EK/Description
- Atmel AT91SAM9263-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9263EK))
-
-
-define Profile/AT91SAM9G15EK
- NAME:=Atmel AT91SAM9G15-EK
-endef
-define Profile/AT91SAM9G15EK/Description
- Atmel AT91SAM9G15-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9G15EK))
-
-
-define Profile/AT91SAM9G20EK
- NAME:=Atmel AT91SAM9G20-EK
-endef
-define Profile/AT91SAM9G20EK/Description
- Atmel AT91SAM9G20-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9G20EK))
-
-
-define Profile/AT91SAM9G20EK-2MMC
- NAME:=Atmel AT91SAM9G20-EK 2MMC
-endef
-define Profile/AT91SAM9G20EK-2MMC/Description
- Atmel AT91SAM9G20-EK eval board with 2 MMC
-endef
-$(eval $(call Profile,AT91SAM9G20EK-2MMC))
-
-
-define Profile/AT91SAM9G25EK
- NAME:=Atmel AT91SAM9G25-EK
-endef
-define Profile/AT91SAM9G25EK/Description
- Atmel AT91SAM9G25-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9G25EK))
-
-
-define Profile/AT91SAM9G35EK
- NAME:=Atmel AT91SAM9G35-EK
-endef
-define Profile/AT91SAM9G35EK/Description
- Atmel AT91SAM9G35-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9G35EK))
-
-
-define Profile/AT91SAM9M10G45EK
- NAME:=Atmel AT91SAM9M10G45-EK
-endef
-define Profile/AT91SAM9M10G45EK/Description
- Atmel AT91SAM9M10G45-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9M10G45EK))
-
-
-define Profile/AT91SAM9X25EK
- NAME:=Atmel AT91SAM9X25-EK
-endef
-define Profile/AT91SAM9X25EK/Description
- Atmel AT91SAM9X25-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9X25EK))
-
-
-define Profile/AT91SAM9X35EK
- NAME:=Atmel AT91SAM9X35-EK
-endef
-define Profile/AT91SAM9X35EK/Description
- Atmel AT91SAM9X35-EK eval board
-endef
-$(eval $(call Profile,AT91SAM9X35EK))
diff --git a/target/linux/at91/legacy/profiles/calamp.mk b/target/linux/at91/legacy/profiles/calamp.mk
deleted file mode 100644
index 33f78e17ac..0000000000
--- a/target/linux/at91/legacy/profiles/calamp.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/LMU5000
- NAME:=CalAmp LMU5000
- PACKAGES:= \
- kmod-rtc-pcf2123 \
- kmod-usb-acm \
- kmod-usb-serial \
- kmod-usb-serial-option \
- kmod-usb-serial-sierrawireless \
- kmod-gpio-mcp23s08
-endef
-
-define Profile/LMU5000/Description
- CalAmp LMU5000
-endef
-
-$(eval $(call Profile,LMU5000))