aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:13 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:00:14 +0200
commitf8a5ac1a8835b9c826286469379a143ff9e532d5 (patch)
treede6365ffeb1cac09e5c69167b5813c238dfbb49d /target/linux/at91/image
parent76ba01a39216b8460846808b2fc10d5ee230a324 (diff)
downloadupstream-f8a5ac1a8835b9c826286469379a143ff9e532d5.tar.gz
upstream-f8a5ac1a8835b9c826286469379a143ff9e532d5.tar.bz2
upstream-f8a5ac1a8835b9c826286469379a143ff9e532d5.zip
at91: Renaming subtarget sama5d3 to sama5
Renaming at91 subtarget sama5d3 to sama5 and using at91-sama5d3_xplained as a target device in sama5 subtarget.This will enable to add other sama5d2 & sama5d4 target devices in sama5 subtraget.This will avoid code duplication when sama5d2 & sama5d4 added as different subtarget. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile5
-rw-r--r--target/linux/at91/image/sama5.mk (renamed from target/linux/at91/image/sama5d3.mk)3
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index d1ae61484a..6e2b6b6101 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -13,8 +13,9 @@ ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
+
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
endif
diff --git a/target/linux/at91/image/sama5d3.mk b/target/linux/at91/image/sama5.mk
index fb02ee1bc0..11d8538dff 100644
--- a/target/linux/at91/image/sama5d3.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -1,8 +1,7 @@
define Device/at91-sama5d3_xplained
$(Device/evaluation-dtb)
- DEVICE_TITLE := Atmel AT91SAMA5D3XPLAINED
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
KERNEL_SIZE := 6144k
SUBPAGESIZE := 2048
endef
TARGET_DEVICES += at91-sama5d3_xplained
-