aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:50 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:22 +0200
commit60750ab505bae8d1cb70c6fe495b755b213a1ebf (patch)
tree66662b19fc1c98ed760389ba61ffe785e4a44e16 /target/linux/at91/image
parentf34b495a2eeebbd29bbd193d50eb490bc03fbde6 (diff)
downloadupstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.tar.gz
upstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.tar.bz2
upstream-60750ab505bae8d1cb70c6fe495b755b213a1ebf.zip
at91: reorganize at91 subtargets
reorganizing at91 subtargets based on sama5 soc features and this fix below problems. 1. able to set neon flags to sama5d2 & sama5d4 subtargets. 2. fix the make clean which removes all the subtargets in bin folder. 3. able to configure kernel specific to subtarget. 4. able to set vfpu4 flags to samad3 subtargets. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile51
-rw-r--r--target/linux/at91/image/sama5.mk101
-rw-r--r--target/linux/at91/image/sama5d2.mk23
-rw-r--r--target/linux/at91/image/sama5d3.mk33
-rw-r--r--target/linux/at91/image/sama5d4.mk19
5 files changed, 124 insertions, 103 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 93180dd64f..49d93aa97d 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,10 +16,21 @@ endef
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
endif
-ifeq ($(SUBTARGET),sama5)
-include ./sama5.mk
+ifeq ($(SUBTARGET),sama5d2)
+include ./sama5d2.mk
+endif
+ifeq ($(SUBTARGET),sama5d3)
+include ./sama5d3.mk
+endif
+ifeq ($(SUBTARGET),sama5d4)
+include ./sama5d4.mk
endif
+AT91_SD_BOOT_PARTSIZE:=64
+FAT32_BLOCK_SIZE:=1024
+FAT32_BLOCKS:=$(shell echo \
+ $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
define Device/Default
$(Device/default-nand)
PROFILES := Default
@@ -35,6 +46,42 @@ define Device/dtb
KERNEL := kernel-bin | lzma | uImage lzma
endef
+define Build/at91-sdcard
+ $(if $(findstring ext4,$@), \
+ rm -f $@.boot
+ mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+
+ mcopy -i $@.boot $(KDIR)/zImage ::zImage
+
+ $(foreach dts,$(DEVICE_DTS), \
+ mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
+ ::$(dts).dtb)
+
+ mcopy -i $@.boot \
+ $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ ::u-boot.bin
+
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+ ::BOOT.bin
+
+ ./gen_at91_sdcard_img.sh \
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+ gzip -nc9 $@.img > $@
+
+ rm -f $@.img $@.boot )
+endef
+
+define Device/evaluation-sdimage
+ IMAGES += sdcard.img.gz
+ IMAGE/sdcard.img.gz := at91-sdcard
+endef
+
define Device/evaluation
KERNEL_INSTALL := 1
KERNEL_SUFFIX := -uImage
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
deleted file mode 100644
index fd7a53421e..0000000000
--- a/target/linux/at91/image/sama5.mk
+++ /dev/null
@@ -1,101 +0,0 @@
-AT91_SD_BOOT_PARTSIZE:=64
-FAT32_BLOCK_SIZE:=1024
-FAT32_BLOCKS:=$(shell echo \
- $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-
-define Build/at91-sdcard
- $(if $(findstring ext4,$@), \
- rm -f $@.boot
- mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-
- mcopy -i $@.boot $(KDIR)/zImage ::zImage
-
- $(foreach dts,$(DEVICE_DTS), \
- mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
- ::$(dts).dtb)
-
- mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
- ::u-boot.bin
-
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
- ::BOOT.bin
-
- ./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-
- gzip -nc9 $@.img > $@
-
- rm -f $@.img $@.boot )
-endef
-
-define Device/evaluation-sdimage
- IMAGES += sdcard.img.gz
- IMAGE/sdcard.img.gz := at91-sdcard
-endef
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d3_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d3_xplained
-
-define Device/at91-sama5d2_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_xplained
-
-define Device/at91-sama5d4_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
- KERNEL_SIZE := 6144k
- BLOCKSIZE := 256k
- PAGESIZE := 4096
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d4_xplained
-
-define Device/at91-sama5d27_som1_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
-
-ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
- ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
- $(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
- DEVICE_PACKAGES := \
- kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
- kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
- kmod-leds-gpio
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
- endef
- TARGET_DEVICES += wb50n
- endif
-endif
diff --git a/target/linux/at91/image/sama5d2.mk b/target/linux/at91/image/sama5d2.mk
new file mode 100644
index 0000000000..28a6f93aad
--- /dev/null
+++ b/target/linux/at91/image/sama5d2.mk
@@ -0,0 +1,23 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d2_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d27_som1_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
diff --git a/target/linux/at91/image/sama5d3.mk b/target/linux/at91/image/sama5d3.mk
new file mode 100644
index 0000000000..f48c981030
--- /dev/null
+++ b/target/linux/at91/image/sama5d3.mk
@@ -0,0 +1,33 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d3_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d3_xplained
+
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ define Device/wb50n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB50N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+ endef
+ TARGET_DEVICES += wb50n
+ endif
+endif
diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
new file mode 100644
index 0000000000..554b9890df
--- /dev/null
+++ b/target/linux/at91/image/sama5d4.mk
@@ -0,0 +1,19 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d4_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ KERNEL_SIZE := 6144k
+ BLOCKSIZE := 256k
+ PAGESIZE := 4096
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d4_xplained