aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:44 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:01 +0200
commit130224cc4754bd4c1cbcd989b6cc1c9aac3246cc (patch)
tree1d49937db6126434c0e741ce442363e6c18f7d7a /target/linux/at91/image
parent87f87e45c0ae8f7f7eadbd479d355232d26cda54 (diff)
downloadupstream-130224cc4754bd4c1cbcd989b6cc1c9aac3246cc.tar.gz
upstream-130224cc4754bd4c1cbcd989b6cc1c9aac3246cc.tar.bz2
upstream-130224cc4754bd4c1cbcd989b6cc1c9aac3246cc.zip
at91: fix sdcard create image
copying at91bootstrap and uboot binaries to sdcard image is done based on device name instead of dts name and this avoids creating multiple u-boot and at91bootstrap binaries. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/sama5.mk16
1 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 5b518c9767..b87588877d 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -11,13 +11,15 @@ define Build/at91-sdcard
$(foreach dts,$(DEVICE_DTS), \
mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
- ::$(dts).dtb; \
- mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(dts:at91-%=%)_mmc/u-boot.bin \
- ::u-boot.bin; \
- $(CP) $(BIN_DIR)/at91bootstrap-$(dts:at91-%=%)sd_uboot*/*.bin \
- $@.BOOT.bin; \
- mcopy -i $@.boot $@.BOOT.bin ::BOOT.bin;)
+ ::$(dts).dtb;)
+
+ mcopy -i $@.boot \
+ $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ ::u-boot.bin
+
+ $(CP) $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+ $@.BOOT.bin; \
+ mcopy -i $@.boot $@.BOOT.bin ::BOOT.bin
./gen_at91_sdcard_img.sh \
$@.img \