aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:17 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:01:02 +0200
commit67303259ee234a4db5d611fdba1f8596e3a7b8b6 (patch)
tree7f5e90fcb52f91aa5ad155b9f83fd2bbeaae850d /target/linux/at91/image
parentfdaaa923ddb9ae18760da11df7d473e7bb950824 (diff)
downloadupstream-67303259ee234a4db5d611fdba1f8596e3a7b8b6.tar.gz
upstream-67303259ee234a4db5d611fdba1f8596e3a7b8b6.tar.bz2
upstream-67303259ee234a4db5d611fdba1f8596e3a7b8b6.zip
at91: Add SAMA5D4 device
Add support for SAMA5D4 with target device as at91-sama5d4_xplained in SAMA5 subtarget and build images for SAMA5D4 Xplained board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/sama5.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 1faeb4baa9..580b51e98f 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -13,3 +13,11 @@ define Device/at91-sama5d2_xplained
SUBPAGESIZE := 2048
endef
TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d4_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ KERNEL_SIZE := 6144k
+ SUBPAGESIZE := 2048
+endef
+TARGET_DEVICES += at91-sama5d4_xplained