aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5d2.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-28 10:21:14 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-30 12:12:37 +0200
commitaff084adf339cf9fd966ce8e2b1173b3ff51fd48 (patch)
tree092b8013cd7f8ed13755f898ad129680c3c715b4 /target/linux/at91/image/sama5d2.mk
parent28e00650a5756cab9405198392e30ae545f2ae4c (diff)
downloadupstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.tar.gz
upstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.tar.bz2
upstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.zip
at91: Merge SAMA5 subtargets
Instead of maintaining 3 very similar subtargets merge them into one. This does not use the Arm NEON extension any more, because the SAMA5D3 does not support NEON. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Sandeep Sheriker <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image/sama5d2.mk')
-rw-r--r--target/linux/at91/image/sama5d2.mk31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/at91/image/sama5d2.mk b/target/linux/at91/image/sama5d2.mk
deleted file mode 100644
index b841448633..0000000000
--- a/target/linux/at91/image/sama5d2.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d2_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_xplained
-
-define Device/at91-sama5d27_som1_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
-
-define Device/at91-sama5d2_ptc_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_ptc_ek