aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-23 20:15:17 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-25 19:28:42 +0200
commit7f1540cc46333e9f96237e0084c554a9ec59068c (patch)
treeffce165b07798c0d42288d47d8060913ee7edf9e /target/linux/at91/image/sama5.mk
parent186569e2e8aac5847ee125c127d500ba024fde0e (diff)
downloadupstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.gz
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.tar.bz2
upstream-7f1540cc46333e9f96237e0084c554a9ec59068c.zip
at91: introduce vendor_model scheme and drop board names
This introduces the vendor_model scheme to this target in order to harmonize device names within the target and with the rest of OpenWrt. In addition, custom board names are dropped in favor of the generic script which takes the compatible. Use the SUPPORTED_DEVICES variable to store the compatible where it deviates from the device name, so we can use it in build recipes. While at it, harmonize a few indents as well. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/at91/image/sama5.mk')
-rw-r--r--target/linux/at91/image/sama5.mk66
1 files changed, 37 insertions, 29 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 031e62587e..d644f89266 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -13,87 +13,94 @@ define Build/at91-sdcard
mcopy -i $@.boot \
$(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
- ::$(DEVICE_NAME:at91-%=%)-fit.itb
+ ::$(DEVICE_NAME)-fit.itb
- $(if $(findstring at91-sama5d27_som1_ek,$@), \
+ $(if $(findstring sama5d27-som1-ek,$@), \
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc1/u-boot.bin \
+ $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc1/u-boot.bin \
::u-boot.bin
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd1_uboot/at91bootstrap.bin \
::BOOT.bin,
mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- $(if $(findstring sama5d4_xplained, $@), \
+ $(if $(findstring sama5d4-xplained,$@), \
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
::BOOT.bin,
mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot/at91bootstrap.bin \
::BOOT.bin))
$(CP) uboot-env.txt $@-uboot-env.txt
sed -i '2d;3d' $@-uboot-env.txt
- sed -i '2i board='"$(DEVICE_NAME:at91-%=%)"'' $@-uboot-env.txt
- sed -i '3i board_name='"$(DEVICE_NAME:at91-%=%)"'' $@-uboot-env.txt
+ sed -i '2i board='"$(DEVICE_NAME)"'' $@-uboot-env.txt
+ sed -i '3i board_name='"$(firstword $(SUPPORTED_DEVICES))"'' $@-uboot-env.txt
mkenvimage -s 0x4000 -o $@-uboot.env $@-uboot-env.txt
mcopy -i $@.boot $@-uboot.env ::uboot.env
./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
gzip -nc9 $@.img > $@
rm -f $@.img $@.boot $@-uboot.env $@-uboot-env.txt)
endef
-define Device/at91-sama5d2_xplained
+define Device/microchip_sama5d2-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D2 Xplained
+ DEVICE_DTS := at91-sama5d2_xplained
+ SUPPORTED_DEVICES := atmel,sama5d2-xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d2_xplained
+TARGET_DEVICES += microchip_sama5d2-xplained
-define Device/at91-sama5d27_som1_ek
+define Device/microchip_sama5d27-som1-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D27 SOM1 Ek
+ DEVICE_DTS := at91-sama5d27_som1_ek
+ SUPPORTED_DEVICES := atmel,sama5d27-som1-ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
+TARGET_DEVICES += microchip_sama5d27-som1-ek
-define Device/at91-sama5d2_ptc_ek
+define Device/microchip_sama5d2-ptc-ek
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D2 PTC Ek
+ DEVICE_DTS := at91-sama5d2_ptc_ek
+ SUPPORTED_DEVICES := atmel,sama5d2-ptc_ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d2_ptc_ek
+TARGET_DEVICES += microchip_sama5d2-ptc-ek
-
-define Device/at91-sama5d3_xplained
+define Device/microchip_sama5d3-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D3 Xplained
+ DEVICE_DTS := at91-sama5d3_xplained
+ SUPPORTED_DEVICES := atmel,sama5d3-xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d3_xplained
+TARGET_DEVICES += microchip_sama5d3-xplained
ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
+ define Device/laird_wb50n
$(Device/evaluation-fit)
DEVICE_VENDOR := Laird
DEVICE_MODEL := WB50N
@@ -106,15 +113,16 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
SUBPAGESIZE := 2048
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
endef
- TARGET_DEVICES += wb50n
+ TARGET_DEVICES += laird_wb50n
endif
endif
-
-define Device/at91-sama5d4_xplained
+define Device/microchip_sama5d4-xplained
$(Device/evaluation-dtb)
DEVICE_VENDOR := Microchip
DEVICE_MODEL := SAMA5D4 Xplained
+ DEVICE_DTS := at91-sama5d4_xplained
+ SUPPORTED_DEVICES := atmel,sama5d4-xplained
KERNEL_SIZE := 6144k
BLOCKSIZE := 256k
PAGESIZE := 4096
@@ -122,4 +130,4 @@ define Device/at91-sama5d4_xplained
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
$(Device/evaluation-sdimage)
endef
-TARGET_DEVICES += at91-sama5d4_xplained
+TARGET_DEVICES += microchip_sama5d4-xplained