aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5.mk
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:16 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:00:44 +0200
commitfdaaa923ddb9ae18760da11df7d473e7bb950824 (patch)
tree9b46d01a860e8ab9bc955270e20c0c52a7b9a656 /target/linux/at91/image/sama5.mk
parentd7a679a036c8b9880301c04f2ce2ac58801e7569 (diff)
downloadupstream-fdaaa923ddb9ae18760da11df7d473e7bb950824.tar.gz
upstream-fdaaa923ddb9ae18760da11df7d473e7bb950824.tar.bz2
upstream-fdaaa923ddb9ae18760da11df7d473e7bb950824.zip
at91: Add SAMA5D2 device
Add support for SAMA5D2 with target device as at91-sama5d2_xplained in SAMA5 subtarget and build images for SAMA5D2 Xplained board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image/sama5.mk')
-rw-r--r--target/linux/at91/image/sama5.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 11d8538dff..1faeb4baa9 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -5,3 +5,11 @@ define Device/at91-sama5d3_xplained
SUBPAGESIZE := 2048
endef
TARGET_DEVICES += at91-sama5d3_xplained
+
+define Device/at91-sama5d2_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ KERNEL_SIZE := 6144k
+ SUBPAGESIZE := 2048
+endef
+TARGET_DEVICES += at91-sama5d2_xplained