aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5.mk
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-04-02 09:34:07 -0700
committerJohn Crispin <john@phrozen.org>2018-04-30 09:01:12 +0200
commit80fe9bd71c18e472c9642e0b70c3abe2c6c21406 (patch)
tree256b96a3bf0f838ae4c0f455b4a13856815a446d /target/linux/at91/image/sama5.mk
parentc0574d08daeae456ef8af562625d083398f08e7e (diff)
downloadupstream-80fe9bd71c18e472c9642e0b70c3abe2c6c21406.tar.gz
upstream-80fe9bd71c18e472c9642e0b70c3abe2c6c21406.tar.bz2
upstream-80fe9bd71c18e472c9642e0b70c3abe2c6c21406.zip
at91: fix build error for wb50n.
when external kernel is selected from menuconfig, device wb50n is not avaliable and build fails. As a fix adding checks for external kernel. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image/sama5.mk')
-rw-r--r--target/linux/at91/image/sama5.mk24
1 files changed, 14 insertions, 10 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index e51a0bce20..5b518c9767 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -71,16 +71,20 @@ define Device/at91-sama5d4_xplained
endef
TARGET_DEVICES += at91-sama5d4_xplained
-define Device/wb50n
- $(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
- DEVICE_PACKAGES := \
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ define Device/wb50n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB50N
+ DEVICE_PACKAGES := \
kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
kmod-leds-gpio
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
-endef
-TARGET_DEVICES += wb50n
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+ endef
+ TARGET_DEVICES += wb50n
+ endif
+endif