aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5.mk
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:47 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:21 +0200
commit22c398d2576b97b5afc67d6802528dc9eceb4d8a (patch)
tree647e6a2057c2441e178549223da07c27e056bbfe /target/linux/at91/image/sama5.mk
parent790b20b6f4744efaf91dd40292996cfb3c5cd8a5 (diff)
downloadupstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.tar.gz
upstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.tar.bz2
upstream-22c398d2576b97b5afc67d6802528dc9eceb4d8a.zip
at91: Add SAMA5D27 SOM1 EK board
Add support for SAMA5D27 SOM1 with target device as at91-sama5d27_som1_ek in SAMA5 subtarget and build images for SAMA5D27 SOM1 Ek board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91/image/sama5.mk')
-rw-r--r--target/linux/at91/image/sama5.mk18
1 files changed, 13 insertions, 5 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index b87588877d..5960f40a3b 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -11,15 +11,15 @@ define Build/at91-sdcard
$(foreach dts,$(DEVICE_DTS), \
mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
- ::$(dts).dtb;)
+ ::$(dts).dtb)
mcopy -i $@.boot \
$(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- $(CP) $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
- $@.BOOT.bin; \
- mcopy -i $@.boot $@.BOOT.bin ::BOOT.bin
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+ ::BOOT.bin
./gen_at91_sdcard_img.sh \
$@.img \
@@ -30,7 +30,7 @@ define Build/at91-sdcard
gzip -nc9 $@.img > $@
- rm -f $@.img $@.boot $@.BOOT.bin
+ rm -f $@.img $@.boot
endef
define Device/evaluation-sdimage
@@ -73,6 +73,14 @@ define Device/at91-sama5d4_xplained
endef
TARGET_DEVICES += at91-sama5d4_xplained
+define Device/at91-sama5d27_som1_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
+
ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
define Device/wb50n