aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/Makefile
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2016-06-10 20:07:32 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:21 +0200
commit86d037e4a27fcf8f465fb1e79db727995ad5c684 (patch)
tree281bf815693ce01a1b75ed576146db18d6b51ce0 /target/linux/at91/image/Makefile
parent618ed77a17422a9e167aed1eeec23a70235d0048 (diff)
downloadupstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.tar.gz
upstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.tar.bz2
upstream-86d037e4a27fcf8f465fb1e79db727995ad5c684.zip
at91: add support for the WB45N module from Laird
This module from Laird includes the following: - CPU Atmel SoC ARM926EJS - Wifi AR6003 - Bluetooth CSR8510 - RAM 64MB LPDDR - FLASH 128MB The flash is a dual image layout, kernel a/b, rootfs a/b, and a user partition. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/at91/image/Makefile')
-rw-r--r--target/linux/at91/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index db480ac754..fedefe4287 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -51,6 +51,12 @@ define Device/evaluation-dtb
IMAGE/dtb := install-dtb
endef
+define Device/evaluation-fit
+ $(Device/evaluation)
+ KERNEL_SUFFIX := -fit-uImage.itb
+ KERNEL := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+endef
+
define Device/production
UBINIZE_OPTS := -E 5
IMAGES := factory.bin