aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/Makefile
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-09-11 18:35:55 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-09-21 01:09:22 +0200
commit612e9ed7b8d2123a64e5617b2f0ea3f99102e31c (patch)
tree7027a8383e845fcf45f0a7a5dcae4f6fe2370ecb /target/linux/at91/image/Makefile
parentab19627ecc3923687fd339f4f23dc45572d00ce0 (diff)
downloadupstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.tar.gz
upstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.tar.bz2
upstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.zip
at91:sama5: create fit image
create fit image & add it to sdcard image for sama5 target device. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'target/linux/at91/image/Makefile')
-rw-r--r--target/linux/at91/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 3b01d42131..adb7c6d0ba 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -63,6 +63,8 @@ define Device/evaluation-dtb
$(Device/evaluation-zImage)
IMAGES += dtb
IMAGE/dtb := install-dtb
+ KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
endef
define Device/evaluation-fit