aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-03 18:51:59 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-03 18:51:59 +0000
commit98eec3e323322222a9a4a6439c6dbd5b11a6ed42 (patch)
treef4854dbfacf5484f67cc9fc8247a68bbcfc91632 /target/linux/at91/image/Makefile
parentcedd3d1a680b77be40cf43f50bd12a5a549805f2 (diff)
downloadupstream-98eec3e323322222a9a4a6439c6dbd5b11a6ed42.tar.gz
upstream-98eec3e323322222a9a4a6439c6dbd5b11a6ed42.tar.bz2
upstream-98eec3e323322222a9a4a6439c6dbd5b11a6ed42.zip
AT91: Add flexibity board support
The patch below adds AT91 Flexibity Connect board support. Signed-off-by: Maxim Osipov <maxim.osipov@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/image/Makefile')
-rw-r--r--target/linux/at91/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 77b8b4bf60..c50732c0c4 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -23,6 +23,9 @@ endef
define Image/BuildKernel
mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
-d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
+ $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
+ fi
endef
define Image/Build