aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
commit2105af06d446c913b2af82ce9c07e2df78952f7a (patch)
treece5f52cf76d23ea9617d1b0630fcb709864ddbc9 /target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
parentfd01a68863b8207e60b15d1ed33bdf76bfe5c867 (diff)
downloadupstream-2105af06d446c913b2af82ce9c07e2df78952f7a.tar.gz
upstream-2105af06d446c913b2af82ce9c07e2df78952f7a.tar.bz2
upstream-2105af06d446c913b2af82ce9c07e2df78952f7a.zip
at91: upgrade to kernel 3.8.7 and use devicetree
This upgrades the AT91 target to 3.8.7, and migrates to device tree. This allows a single kernel to be built for most at91 variants which simplifies things quite a bit. The immediate result is that all subtargets are nuked, and any boards without dts files are no longer supported, though the target now includes more boards than before. The adc driver was also nuked as 3.8.7 includes a new one under the IIO subsystem. Signed-off-by: Adam Porter <porter.adam@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36452 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/9260/profiles/001-flexibity-xwrt.mk')
-rw-r--r--target/linux/at91/9260/profiles/001-flexibity-xwrt.mk26
1 files changed, 0 insertions, 26 deletions
diff --git a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
deleted file mode 100644
index fcd06999fd..0000000000
--- a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Copyright (C) 2011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/flexibity-xwrt
- NAME:=Flexibity Connect (XWrt)
- PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev webif webif-applications webif-flexibity \
- syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
- iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
- usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
- fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
- gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
- file flock gdbserver gnupg gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
- module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
- usb-modeswitch usb-modeswitch-data usbutils lua
-endef
-
-define Profile/flexibity-xwrt/Description
- Complete packages set for the Flexibity Connect device (XWrt).
-endef
-
-$(eval $(call Profile,flexibity-xwrt))
-