aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-04 17:29:44 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-04 17:29:44 +0000
commit8457941aceff0530aa9f9dbaabb3c7f311645d89 (patch)
treee5f4f96eafbe453186ebf8c8aa226d4c7e40079a /target/linux/at91-2.6/image
parenta976a6d4b420918c3260789d7acef81ac4a0173b (diff)
downloadupstream-8457941aceff0530aa9f9dbaabb3c7f311645d89.tar.gz
upstream-8457941aceff0530aa9f9dbaabb3c7f311645d89.tar.bz2
upstream-8457941aceff0530aa9f9dbaabb3c7f311645d89.zip
Added initial support for at91 plaform (HCG)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6508 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image')
-rw-r--r--target/linux/at91-2.6/image/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/Makefile b/target/linux/at91-2.6/image/Makefile
new file mode 100644
index 0000000000..07660f2350
--- /dev/null
+++ b/target/linux/at91-2.6/image/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+TARGET_DEVICE_TABLE:=$(TOPDIR)/target/linux/vlink-2.6/image/device_table.txt
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))