aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-04 17:29:44 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-04 17:29:44 +0000
commit99657a3be53db1dc4eb435de8e61eaabfd30fd50 (patch)
tree1ad122c56d6913acc7b4c14200c8bb3876cacc49 /target/linux/at91-2.6/Makefile
parentbc60eb3610c458c103576ef9bbceee9abcef2922 (diff)
downloadupstream-99657a3be53db1dc4eb435de8e61eaabfd30fd50.tar.gz
upstream-99657a3be53db1dc4eb435de8e61eaabfd30fd50.tar.bz2
upstream-99657a3be53db1dc4eb435de8e61eaabfd30fd50.zip
Added initial support for at91 plaform (HCG)
SVN-Revision: 6508
Diffstat (limited to 'target/linux/at91-2.6/Makefile')
-rw-r--r--target/linux/at91-2.6/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/Makefile b/target/linux/at91-2.6/Makefile
new file mode 100644
index 0000000000..982a91139f
--- /dev/null
+++ b/target/linux/at91-2.6/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=at91
+BOARDNAME:=AT91
+FEATURES:=squashfs
+
+define Target/Description
+ Build fimware images for Figment Design Labs VersaLink board.
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+#include the profiles
+-include profiles/*.mk
+
+KERNELNAME:="uImage"
+$(eval $(call BuildKernel))