aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armvirt/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-03-28 14:34:26 +0000
committerPetr Štetiar <ynezz@true.cz>2019-06-25 14:12:22 +0000
commit53f4a686aa8d0740c0a5b8626da6435c130de8d1 (patch)
treebcb1c2c4cb1449344ed9777ad136b587eeec2a26 /target/linux/armvirt/Makefile
parentd9426d537bcd35f4f748c985bc33f2861e0b3dd2 (diff)
downloadupstream-53f4a686aa8d0740c0a5b8626da6435c130de8d1.tar.gz
upstream-53f4a686aa8d0740c0a5b8626da6435c130de8d1.tar.bz2
upstream-53f4a686aa8d0740c0a5b8626da6435c130de8d1.zip
armvirt: fix overlay support by updating to f2fs/ext4 based overlays
Current snapshot images doesn't provide images with usable overlay filesystems: mount_root: no usable overlay filesystem found, using tmpfs overlay So this patch fixes this by updating support to current f2fs/ext4 based overlays and providing squashfs with proper rootfs TARGET_ROOTFS_PARTSIZE size. While at it, I've also added support for optional gzipping of the images, and renamed the output rootfs image filenames to match the more common naming pattern $(IMG_PREFIX)-rootfs-$(FS-TYPE).img. Cc: Yousong Zhou <yszhou4tech@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/armvirt/Makefile')
-rw-r--r--target/linux/armvirt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/armvirt/Makefile b/target/linux/armvirt/Makefile
index 9a67ab66a4..44d4ece224 100644
--- a/target/linux/armvirt/Makefile
+++ b/target/linux/armvirt/Makefile
@@ -17,4 +17,6 @@ KERNEL_PATCHVER:=4.19
include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
$(eval $(call BuildTarget))