aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armvirt/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-12-08 23:21:30 +0800
committerJohn Crispin <john@phrozen.org>2016-12-16 07:56:35 +0100
commit44ecfc26eb22ca23668a5fd0c706d75f274e410a (patch)
treeb4b3df9deb3c5f8e62296723b0937694ecdb5c25 /target/linux/armvirt/Makefile
parentfb237477fd1e7801e4877f9fe1ea7bc1ec16dd99 (diff)
downloadupstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.tar.gz
upstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.tar.bz2
upstream-44ecfc26eb22ca23668a5fd0c706d75f274e410a.zip
armvirt: new target
An ARM Cortex-A15 machine provided by QEMU. Kernel drivers enabled: - pl011, uart - pl031, rtc - pl061, gpio - pci-host-generic - virtio_{mmio,pci,net,blk,scsi,9p,console,balloon} - smp with NR_CPUS=4 - cpu-hotplug - ext4 - neon, vfp extensions support (otherwise userland will fail with illegal instruction signal (code 0x00000004)) - DEBUG_BUGVERBOSE for debug purposes Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/armvirt/Makefile')
-rw-r--r--target/linux/armvirt/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/armvirt/Makefile b/target/linux/armvirt/Makefile
new file mode 100644
index 0000000000..b91e932e68
--- /dev/null
+++ b/target/linux/armvirt/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=armvirt
+BOARDNAME:=QEMU ARM Virtual Machine
+FEATURES:=fpu pci rtc
+FEATURES+=cpiogz ext4 ramdisk squashfs targz
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+
+KERNEL_PATCHVER:=4.4
+
+define Target/Description
+ Build images for QEMU ARM Virtual Machine
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
+
+$(eval $(call BuildTarget))