aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armsr/Makefile
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-06-09 00:43:33 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-13 14:14:29 +0200
commit7198185e3af80ca2807ecea610bee6e4bc7f90ba (patch)
treeef3773fd059a859291cfee68590ebf6863c16931 /target/linux/armsr/Makefile
parent963ce6990f231d9457cf700275963563901c05cc (diff)
downloadupstream-7198185e3af80ca2807ecea610bee6e4bc7f90ba.tar.gz
upstream-7198185e3af80ca2807ecea610bee6e4bc7f90ba.tar.bz2
upstream-7198185e3af80ca2807ecea610bee6e4bc7f90ba.zip
armsr: rename from armvirt
Now that the armvirt target supports real hardware, not just VMs, thanks to the addition of EFI, rename it to something more appropriate. 'armsr' (Arm SystemReady) was chosen after the name of the Arm standards program. The 32 and 64 bit targets have also been renamed armv7 and armv8 respectively, to allow future profiles where required (such as armv9). See https://developer.arm.com/documentation/102858/0100/Introduction for more information. Signed-off-by: Mathew McBride <matt@traverse.com.au> (23.05 version of commit 40b02a230167626def69389452f19b7109aaeac1)
Diffstat (limited to 'target/linux/armsr/Makefile')
-rw-r--r--target/linux/armsr/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/armsr/Makefile b/target/linux/armsr/Makefile
new file mode 100644
index 0000000000..755c77f446
--- /dev/null
+++ b/target/linux/armsr/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+
+include $(TOPDIR)/rules.mk
+
+BOARD:=armsr
+BOARDNAME:=Arm SystemReady (EFI) compliant
+FEATURES:=fpu pci pcie rtc usb boot-part rootfs-part
+FEATURES+=cpiogz ext4 ramdisk squashfs targz vmdk
+
+KERNEL_PATCHVER:=5.15
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+# blkid used for resolving PARTUUID
+# in sysupgrade
+DEFAULT_PACKAGES += blkid
+
+$(eval $(call BuildTarget))