aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
commita2768bd9e0efb430e864fe5faf5070ea724e2797 (patch)
tree49fdd25cfab8faf7ab938fdd04da204fb43926cd /target/linux/arm64/Makefile
parentacf46919048fba514abf4d263e59e70eaddeb3ae (diff)
downloadupstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.gz
upstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.bz2
upstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.zip
arm64: add ARM 64-bits target
This target can be emulated using ARM's Foundation_V8 simulator software or qemu-system-aarch64 using the command-line described in the README file. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43355
Diffstat (limited to 'target/linux/arm64/Makefile')
-rw-r--r--target/linux/arm64/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/arm64/Makefile b/target/linux/arm64/Makefile
new file mode 100644
index 0000000000..a30430bb70
--- /dev/null
+++ b/target/linux/arm64/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=arm64
+BOARDNAME:=ARMv8 multiplatform
+FEATURES:=fpu ramdisk
+CFLAGS:=-Os -pipe -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+KERNEL_PATCHVER:=3.14
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build multi-platform images for the ARMv8 instruction set architecture
+endef
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))
01 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368