aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/archs38/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-18 08:22:32 +0000
committerJohn Crispin <john@openwrt.org>2016-02-18 08:22:32 +0000
commit73015c4cb3787cccadc72b53fdb84b2d45c90136 (patch)
treecea0bb920bf3d0e71a37a09ef861eccc353fdf69 /target/linux/archs38/generic
parent7b821a5ae882cb0c70fd9d09ec9d5952985951dc (diff)
downloadupstream-73015c4cb3787cccadc72b53fdb84b2d45c90136.tar.gz
upstream-73015c4cb3787cccadc72b53fdb84b2d45c90136.tar.bz2
upstream-73015c4cb3787cccadc72b53fdb84b2d45c90136.zip
linux: add support of Synopsys ARCHS38-based boards
This patch introduces support of new boards with ARC HS38 cores. ARC HS38 is a new generation of ARC cores which utilize ARCv2 ISA. As with ARC770 we're addind support for 2 boards for now: [1] Synopsys SDP board (AXS103) This is the same base-board as in AXS101 but with FPGA-based CPU-tile where ARCHs38 core is implemented. [2] nSIM Again this is the same simulation engine but configured for new instruction set and features of new CPU. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 48740
Diffstat (limited to 'target/linux/archs38/generic')
-rw-r--r--target/linux/archs38/generic/profiles/00-default.mk16
-rw-r--r--target/linux/archs38/generic/profiles/01-minimal.mk15
-rw-r--r--target/linux/archs38/generic/profiles/02-axs103.mk16
-rw-r--r--target/linux/archs38/generic/profiles/03-nsim_hs.mk15
-rw-r--r--target/linux/archs38/generic/target.mk8
5 files changed, 70 insertions, 0 deletions
diff --git a/target/linux/archs38/generic/profiles/00-default.mk b/target/linux/archs38/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..10edb88ff9
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-mmc kmod-sdhci
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/archs38/generic/profiles/01-minimal.mk b/target/linux/archs38/generic/profiles/01-minimal.mk
new file mode 100644
index 0000000000..fe8d8c3a59
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/01-minimal.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Minimal
+ NAME:=Minimal Profile (no drivers)
+endef
+
+define Profile/Minimal/Description
+ Minimal package set compatible with most boards.
+endef
+$(eval $(call Profile,Minimal))
diff --git a/target/linux/archs38/generic/profiles/02-axs103.mk b/target/linux/archs38/generic/profiles/02-axs103.mk
new file mode 100644
index 0000000000..4a8ea3a1db
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/02-axs103.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/axs103
+ NAME:=Synopsys DesignWare AXS103
+ PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-mmc kmod-sdhci
+endef
+
+define Profile/axs103/Description
+ Package set compatible with hardware using Synopsys DesignWare AXS103 boards.
+endef
+$(eval $(call Profile,axs103))
diff --git a/target/linux/archs38/generic/profiles/03-nsim_hs.mk b/target/linux/archs38/generic/profiles/03-nsim_hs.mk
new file mode 100644
index 0000000000..cebb0a66f4
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/03-nsim_hs.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/nsim_hs
+ NAME:=Synopsys nSIM
+endef
+
+define Profile/nsim_hs/Description
+ Package set compatible with hardware using Synopsys nSIM HS boards.
+endef
+$(eval $(call Profile,nsim_hs))
diff --git a/target/linux/archs38/generic/target.mk b/target/linux/archs38/generic/target.mk
new file mode 100644
index 0000000000..19b310e2c0
--- /dev/null
+++ b/target/linux/archs38/generic/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Generic
+FEATURES += ramdisk usb
+
+define Target/Description
+ Build firmware images for generic ARC HS38 based boards.
+endef
+
+