aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-05-01 22:15:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-05-01 22:15:18 +0000
commit8a9fe26f201e996d4850cd3b3e770421bb4c4754 (patch)
tree000d22e0a0851ebbbb292c7ba9923f4a8415d011 /target/linux/ar71xx
parentdb02b0e4eeeec8cb707298bdea3422e90bd39dd6 (diff)
downloadupstream-8a9fe26f201e996d4850cd3b3e770421bb4c4754.tar.gz
upstream-8a9fe26f201e996d4850cd3b3e770421bb4c4754.tar.bz2
upstream-8a9fe26f201e996d4850cd3b3e770421bb4c4754.zip
kernel: update linux 3.8 to 3.8.11
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36507
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index baaccdaa82..3ce41a4c91 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.8.10
+LINUX_VERSION:=3.8.11
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch
index 8c2a182803..19c1c72f75 100644
--- a/target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch
@@ -191,7 +191,7 @@
/*
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3868,13 +3868,14 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3896,13 +3896,14 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);
@@ -279,7 +279,7 @@
#include <asm/uaccess.h>
#include <linux/proc_fs.h>
-@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
+@@ -764,10 +765,10 @@ static void tcp_v6_send_response(struct
topt = (__be32 *)(t1 + 1);
if (ts) {