aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2018-09-11 23:50:56 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-02-08 17:27:47 +0100
commit7ebbbda29377f2d95e2bb9690f348af50ade848a (patch)
tree06c947c838de89605a2044a75e2b595f146e6105 /target/linux/ar71xx
parent6570f3c93aa4110efd1466a6b89742c2e11d7c11 (diff)
downloadupstream-7ebbbda29377f2d95e2bb9690f348af50ade848a.tar.gz
upstream-7ebbbda29377f2d95e2bb9690f348af50ade848a.tar.bz2
upstream-7ebbbda29377f2d95e2bb9690f348af50ade848a.zip
ar71xx: ubnt-(xm,xw): fix LED RSSI indication
When mapping for RSSI LEDs was defined for interface wlan0 on Ubiquiti XM and XW family, it missed connection to actual interface. Therefore create the mapping to interface, so RSSI LEDs work without additional configuration, after starting rssileds service. Also add the required package for this. While at that, remove coefficients needed for PWM LEDs, as XM and XW boards do not support PWM LEDs. Tested-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Lech Perczak <lech.perczak@gmail.com> [Squashed commits + remove custom device_packages + slighty rewrite the commit msg] Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ar71xx')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds9
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk2
2 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 5c9397f0f7..170adaa7a2 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -184,10 +184,11 @@ nanostation-m|\
nanostation-m-xw|\
rocket-m|\
rocket-m-xw)
- ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:red:link1" "wlan0" "1" "100" "0" "13"
- ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "ubnt:orange:link2" "wlan0" "26" "100" "-25" "13"
- ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "ubnt:green:link3" "wlan0" "51" "100" "-50" "13"
- ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:red:link1" "wlan0" "1" "100"
+ ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "ubnt:orange:link2" "wlan0" "26" "100"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "ubnt:green:link3" "wlan0" "51" "100"
+ ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link4" "wlan0" "76" "100"
;;
bxu2000n-2-a1)
ucidef_set_led_wlan "wlan" "WLAN" "bhu:green:wlan" "phy0tpt"
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index 42275bae18..ac02be57db 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -49,7 +49,7 @@ endef
define Device/ubnt-xm
$(Device/ubnt)
- DEVICE_PACKAGES += kmod-usb-ohci
+ DEVICE_PACKAGES += kmod-usb-ohci rssileds
UBNT_TYPE := XM
UBNT_CHIP := ar7240
KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma | uImage lzma