aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorMarty Plummer <ntzrmtthihu777@gmail.com>2017-04-14 12:08:17 -0500
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-30 14:15:25 +0200
commit558d86923e3f5a62577036aa2bace2532163ca13 (patch)
tree01947ffaa9ab4341c6719e9fbd452b68f61a8cfa /target/linux/ar71xx
parent0f21873f7f1465f9ddd0ebde11716b966cb7665e (diff)
downloadupstream-558d86923e3f5a62577036aa2bace2532163ca13.tar.gz
upstream-558d86923e3f5a62577036aa2bace2532163ca13.tar.bz2
upstream-558d86923e3f5a62577036aa2bace2532163ca13.zip
ar71xx: add support for EnGenius ENS202EXT
EnGenius ENS202EXT is an outdoor wireless access point with 2-port 10/100 switch, detachable antennas and proprietery PoE. The device is based on Qualcomm/Atheros AR9341 v1. Specifications: - 535/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM - 16 MB of FLASH - UART (J1) header on PCB (unpopulated) - 2x 10/100 Mbps Ethernet - 2.4 GHz, up to 26dBm - 2x external, detachable antennas - 7x LED, 1x button Flash instructions: You have three options: - Use the vendor firmware upgrade page on the web interface and give it the factory.img. This is the easiest way to go about it. - If you have serial access during u-boot, interrupt the normal boot (any key before timeout) and run 'run failsafe_boot'; this will bring you to a minimal openwrt luci image on ip 192.168.1.1 useful if you've bricked the normal firmware. - Use the vendor's management cli, which can be accessed via telnet with the same credentials as the web login (default admin:admin), then issue the following commands: *** Hi admin, welcome to use cli(V-1.6.7) *** ---========= Commands Help =========--- stat -- Status sys -- System wless2 -- 2.4G-Wireless mgmt -- Management tree -- Tree help -- Help reboot -- Reboot ens202ext>mgmt Management ---========= Commands Help =========--- admin -- Administration mvlan -- Management VLAN settings snmp -- SNMP settings backup -- Backup/Restore settings autorb -- Auto reboot settings fwgrade -- Firmware upgrade time -- Time settings wifisch -- Wifi schedule log -- Log diag -- Diagnostics disc -- Device Discovery logout -- Logout help -- Help exit -- Exit ens202ext/mgmt>fwgrade Management --> Firmware upgrade ---========= Commands Help =========--- fwup -- Firmware upgrade help -- Help exit -- Exit ens202ext/mgmt/fwgrade>fwup http://web.server/lede-ar71xx-generic-ens202ext-squashfs-factory.bin Signed-off-by: Marty Plummer <ntzrmtthihu777@gmail.com>
Diffstat (limited to 'target/linux/ar71xx')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds7
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh4
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-ens202ext.c124
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/Makefile1
-rw-r--r--target/linux/ar71xx/image/senao.mk26
11 files changed, 179 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 59a14271a7..7248ab1941 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -220,6 +220,13 @@ eap300v2)
ucidef_set_led_netdev "lan" "LAN" "engenius:blue:lan" "eth0"
ucidef_set_led_wlan "wlan" "WLAN" "engenius:blue:wlan" "phy0tpt"
;;
+ens202ext)
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "rssilow" "RSSILOW" "engenius:amber:wlan1" "wlan0" "1" "100" "0" "13"
+ ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "engenius:red:wlan2" "wlan0" "25" "100" "-39" "13"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "engenius:amber:wlan3" "wlan0" "50" "100" "-59" "13"
+ ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "engenius:green:wlan4" "wlan0" "75" "100" "-79" "13"
+ ;;
f9k1115v2)
ucidef_set_led_usbdev "usb2" "USB2" "belkin:green:usb2" "1-1"
;;
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index ef48b133bd..ae43351c6a 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -175,6 +175,9 @@ get_status_led() {
eap300v2)
status_led="engenius:blue:power"
;;
+ ens202ext)
+ status_led="engenius:amber:power"
+ ;;
eap7660d)
status_led="$board:green:ds4"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index db5de727c1..e781c6ee7e 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -625,6 +625,9 @@ ar71xx_board_detect() {
*"EmbWir-Dorin-Router")
name="ew-dorin-router"
;;
+ *"ENS202EXT")
+ name="ens202ext"
+ ;;
*"EPG5000")
name="epg5000"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 848aeffacc..16701f64ca 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -236,6 +236,7 @@ platform_check_image() {
dr531|\
dragino2|\
ebr-2310-c1|\
+ ens202ext|\
epg5000|\
esr1750|\
esr900|\
@@ -757,7 +758,8 @@ platform_do_upgrade() {
platform_do_upgrade_allnet "0x9f080000" "$ARGV"
;;
cap4200ag|\
- eap300v2)
+ eap300v2|\
+ ens202ext)
platform_do_upgrade_allnet "0xbf0a0000" "$ARGV"
;;
dir-825-b1|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 298b3ebcbb..43a487d20e 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -100,6 +100,7 @@ CONFIG_ATH79_MACH_EAP300V2=y
CONFIG_ATH79_MACH_EAP7660D=y
CONFIG_ATH79_MACH_EL_M150=y
CONFIG_ATH79_MACH_EL_MINI=y
+CONFIG_ATH79_MACH_ENS202EXT=y
CONFIG_ATH79_MACH_EPG5000=y
CONFIG_ATH79_MACH_ESR1750=y
CONFIG_ATH79_MACH_ESR900=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 70c27a65be..c18eec557d 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -767,6 +767,15 @@ config ATH79_MACH_EAP120
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_ENS202EXT
+ bool "EnGenius ENS202EXT support"
+ select SOC_AR934X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_EAP300V2
bool "EnGenius EAP300 v2 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index bc3f6819be..55c5a2a939 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -104,6 +104,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2) += mach-eap300v2.o
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
+obj-$(CONFIG_ATH79_MACH_ENS202EXT) += mach-ens202ext.o
obj-$(CONFIG_ATH79_MACH_EPG5000) += mach-epg5000.o
obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ens202ext.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ens202ext.c
new file mode 100644
index 0000000000..07dbc2e69d
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-ens202ext.c
@@ -0,0 +1,124 @@
+/*
+ * EnGenius ENS202EXT board support
+ *
+ * Copyright (C) 2017 Marty Plummer <netz.kernel@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <asm/mach-ath79/ath79.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "nvram.h"
+
+#define ENS202_GPIO_LED_WLAN4 0
+#define ENS202_GPIO_LED_POWER 14
+#define ENS202_GPIO_LED_WLAN2 16
+#define ENS202_GPIO_LED_WLAN3 17
+#define ENS202_GPIO_LED_WLAN1 18
+
+#define ENS202_GPIO_BTN_RESET 1
+
+#define ENS202_KEYS_POLL_INTERVAL 20 /* msecs */
+#define ENS202_KEYS_DEBOUNCE_INTERVAL (3 * ENS202_KEYS_POLL_INTERVAL)
+
+static struct gpio_led ens202_leds_gpio[] __initdata = {
+ {
+ .name = "engenius:amber:wlan1",
+ .gpio = ENS202_GPIO_LED_WLAN1,
+ .active_low = 1,
+ }, {
+ .name = "engenius:red:wlan2",
+ .gpio = ENS202_GPIO_LED_WLAN2,
+ .active_low = 1,
+ }, {
+ .name = "engenius:amber:wlan3",
+ .gpio = ENS202_GPIO_LED_WLAN3,
+ .active_low = 1,
+ }, {
+ .name = "engenius:green:wlan4",
+ .gpio = ENS202_GPIO_LED_WLAN4,
+ .active_low = 1,
+ }, {
+ .name = "engenius:amber:power",
+ .gpio = ENS202_GPIO_LED_POWER,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button ens202_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = ENS202_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = ENS202_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+static void __init ens202_setup(void)
+{
+ const char *nvram = (char *) KSEG1ADDR(0x1f040000);
+ u8 mac_buff[6];
+ u8 *mac = NULL;
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ if (ath79_nvram_parse_mac_addr(nvram, 0x10000,
+ "ethaddr=", mac_buff) == 0) {
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac_buff, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac_buff, 1);
+ mac = mac_buff;
+ }
+
+ ath79_gpio_function_enable(AR934X_GPIO_FUNC_JTAG_DISABLE);
+
+ ath79_gpio_output_select(ENS202_GPIO_LED_POWER, AR934X_GPIO_OUT_GPIO);
+ ath79_gpio_output_select(ENS202_GPIO_LED_WLAN1, AR934X_GPIO_OUT_GPIO);
+ ath79_gpio_output_select(ENS202_GPIO_LED_WLAN2, AR934X_GPIO_OUT_GPIO);
+ ath79_gpio_output_select(ENS202_GPIO_LED_WLAN3, AR934X_GPIO_OUT_GPIO);
+ ath79_gpio_output_select(ENS202_GPIO_LED_WLAN4, AR934X_GPIO_OUT_GPIO);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(ens202_leds_gpio),
+ ens202_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, ENS202_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(ens202_gpio_keys),
+ ens202_gpio_keys);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_wmac(art + 0x1000, NULL);
+
+ ath79_register_mdio(1, 0);
+
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0 |
+ AR934X_ETH_CFG_SW_ONLY_MODE);
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+ ath79_eth0_pll_data.pll_1000 = 0x06000000;
+
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+
+ ath79_register_eth(0);
+ ath79_register_eth(1);
+}
+
+MIPS_MACHINE(ATH79_MACH_ENS202EXT, "ENS202EXT", "EnGenius ENS202EXT",
+ ens202_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index ddb91ad46d..0d05086a1c 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -95,6 +95,7 @@ enum ath79_mach_type {
ATH79_MACH_EBR_2310_C1, /* D-link EBR-2310 rev. C1 */
ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
+ ATH79_MACH_ENS202EXT, /* EnGenius ENS202EXT */
ATH79_MACH_EPG5000, /* EnGenius EPG5000 */
ATH79_MACH_ESR1750, /* EnGenius ESR1750 */
ATH79_MACH_ESR900, /* EnGenius ESR900 */
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8eac5fc997..32951e5347 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -17,6 +17,7 @@ include ./tp-link.mk
include ./ubnt.mk
include ./generic.mk
include ./legacy-devices.mk
+include ./senao.mk
endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk
diff --git a/target/linux/ar71xx/image/senao.mk b/target/linux/ar71xx/image/senao.mk
new file mode 100644
index 0000000000..50d3ccdfe1
--- /dev/null
+++ b/target/linux/ar71xx/image/senao.mk
@@ -0,0 +1,26 @@
+define Build/senao-factory-image
+ $(eval board=$(word 1,$(1)))
+ $(eval rootfs=$(word 2,$(1)))
+
+ mkdir -p $@.senao
+
+ touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(board)
+ $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(board)-uImage-lzma.bin
+ $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
+
+ $(TAR) -czf $@ -C $@.senao .
+ rm -rf $@.senao
+endef
+
+define Device/ens202ext
+ DEVICE_TITLE := EnGenius ENS202EXT
+ BOARDNAME := ENS202EXT
+ DEVICE_PACKAGES += rssileds
+ KERNEL_SIZE := 1536k
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | check-size $$(KERNEL_SIZE)
+ IMAGE_SIZE := 12096k
+ IMAGES += factory.bin
+ IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,13632k(firmware),2048k(failsafe)ro,64k(art)ro
+endef
+TARGET_DEVICES += ens202ext