aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorAndreas Ziegler <dev@andreas-ziegler.de>2019-10-22 22:44:29 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-23 12:31:48 +0200
commit2bc7c519dcc0e7ca09feed24a3b9a105bc49f423 (patch)
tree1285885304c82283dbaad40df7fc0c0ee7b039f8 /target/linux/ar71xx
parent7f187229a8e9b7966248b1e024217e07a9fc3e50 (diff)
downloadupstream-2bc7c519dcc0e7ca09feed24a3b9a105bc49f423.tar.gz
upstream-2bc7c519dcc0e7ca09feed24a3b9a105bc49f423.tar.bz2
upstream-2bc7c519dcc0e7ca09feed24a3b9a105bc49f423.zip
ar71xx: add model detection for UniFi AC-LR
This commit adds correct model detection for UniFi AC-LR. Previously, said device was incorrectly detected as UniFi-AC-LITE/MESH. The Information about the device is stored at 0xC in the EEPROM partition. It corresponds to the sysid in /etc/board.info of the Ubiquiti stock firmware. Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de> [adjust naming style of target to existing ones] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ar71xx')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 03dfbcebf9..044ef4eae5 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -111,6 +111,9 @@ ubnt_unifi_ac_board_detect() {
"e517")
model="Ubiquiti UniFi-AC-LITE"
;;
+ "e527")
+ model="Ubiquiti UniFi-AC-LR"
+ ;;
"e537")
model="Ubiquiti UniFi-AC-PRO"
;;
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index 5a4517f81f..b82ac8686f 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -138,6 +138,12 @@ define Device/ubnt-unifiac-lite
endef
TARGET_DEVICES += ubnt-unifiac-lite
+define Device/ubnt-unifiac-lr
+ $(Device/ubnt-unifiac-lite)
+ DEVICE_TITLE := Ubiquiti UniFi AC-LR
+endef
+TARGET_DEVICES += ubnt-unifiac-lr
+
define Device/ubnt-unifiac-mesh
$(Device/ubnt-unifiac-lite)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh