aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-04-04 14:16:19 +0200
committerPetr Štetiar <ynezz@true.cz>2019-04-11 22:54:45 +0200
commitc7eb679047dbc3a15b3eb4d5e5fa376c42f4c7b1 (patch)
tree3acda6729aec3e0e20511b8fc84370ba0048914b /target/linux/ar71xx
parent9c4fa1bb5bfdc756a3fbfce6360fddfdb67f083a (diff)
downloadupstream-c7eb679047dbc3a15b3eb4d5e5fa376c42f4c7b1.tar.gz
upstream-c7eb679047dbc3a15b3eb4d5e5fa376c42f4c7b1.tar.bz2
upstream-c7eb679047dbc3a15b3eb4d5e5fa376c42f4c7b1.zip
ar71xx: Add "info" partition for TP-Link Archer C7 v5
This adds the "info" MTD partition, as it is specified in the ath79 DTS: https://github.com/openwrt/openwrt/blob/master/target/linux/ath79/dts/qca9563_tplink_archer-c7-v5.dts#L35 This is required to set the WAN MAC address, as it is build based on the LAN MAC address, which in turn has to be read from the "info" partition: https://github.com/openwrt/openwrt/blob/master/target/linux/ath79/dts/qca9563_tplink_archer-x7-v5.dtsi#L184 Backport of commit 9aa8f87d277bf2f666fa5bf90c5efd59dd044d54 Tested-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index 86d1aa41e3..c2062c8511 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -147,7 +147,7 @@ define Device/archer-c7-v5
BOARDNAME := ARCHER-C7-V5
TPLINK_BOARD_ID := ARCHER-C7-V5
IMAGE_SIZE := 15104k
- MTDPARTS := spi0.0:128k(factory-uboot)ro,128k(u-boot)ro,64k@0x50000(art)ro,1536k@0xc0000(kernel),13824k(rootfs),15360k@0xc0000(firmware)
+ MTDPARTS := spi0.0:128k(factory-uboot)ro,128k(u-boot)ro,64k@0x50000(art)ro,128k@0x60000(info)ro,1536k@0xc0000(kernel),13824k(rootfs),15360k@0xc0000(firmware)
SUPPORTED_DEVICES := archer-c7-v5
endef
TARGET_DEVICES += archer-c7-v5