aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-22 20:14:22 +0000
commitccc96f79d58f57ba1161da4c4cea90a94cf85804 (patch)
tree172f2fafea1c02306c1f4e5cf85cbb211c42e5fa /target/linux/ar71xx
parent8d82afd3a48d99a9cc8b29aa44827c252272b4aa (diff)
downloadupstream-ccc96f79d58f57ba1161da4c4cea90a94cf85804.tar.gz
upstream-ccc96f79d58f57ba1161da4c4cea90a94cf85804.tar.bz2
upstream-ccc96f79d58f57ba1161da4c4cea90a94cf85804.zip
ar71xx: image: remove too big files in the CatFiles macro
Also improve the warning message. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38125 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index bb6f6124f8..65ddabec15 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -115,7 +115,8 @@ define CatFiles
esac; \
( dd if=$(1) bs=$$$${bs} conv=sync; cat $(3) ) > $(5); \
if [ `stat -c%s $(5)` -gt $(4) ]; then \
- echo "Warning: $(1) is too big" >&2; \
+ echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
+ rm -f $(5); \
fi; \
else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
echo "Warning: $(1) is too big" >&2; \