aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-24 13:55:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-24 13:55:40 +0000
commitf9f60dce007f75420b0fc38df2ee8c1711bc609c (patch)
tree41868addd5ee2adde5c28f246d75032d55852070 /target/linux/ar71xx
parentb9a877473540283c47e02549917515adac85ff09 (diff)
downloadupstream-f9f60dce007f75420b0fc38df2ee8c1711bc609c.tar.gz
upstream-f9f60dce007f75420b0fc38df2ee8c1711bc609c.tar.bz2
upstream-f9f60dce007f75420b0fc38df2ee8c1711bc609c.zip
ar71xx: the squashfs-4k images are unreliable in some builds. add 4k, 8k padding to the generic squashfs images and use them on 4k devices as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 33937e4028..ed623de20c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -276,7 +276,7 @@ define Image/Build/Template/TPLINK4K
endef
define Image/Build/Template/TPLINK4K/squashfs
- $(call Image/Build/Template/TPLINK,squashfs-4k,$(1),$(2),$(3))
+ $(call Image/Build/Template/TPLINK,squashfs,$(1),$(2),$(3))
endef
define Image/Build/Template/UBNT
@@ -296,7 +296,7 @@ define Image/Build/Template/UBNTXM
endef
define Image/Build/Template/UBNTXM/squashfs
- $(call Image/Build/Template/UBNTXM,squashfs-4k,$(1),$(2),$(3),$(4),$(5))
+ $(call Image/Build/Template/UBNTXM,squashfs,$(1),$(2),$(3),$(4),$(5))
endef
define Image/Build/Template/UBNTXM/jffs2-64k
@@ -428,8 +428,6 @@ define Image/Build/Profile/Madwifi
endef
define Image/Build/squashfs
- dd if=$(KDIR)/root.squashfs of=$(IMGNAME)-root.squashfs-4k bs=4k conv=sync
- $(call add_jffs2_mark,$(IMGNAME)-root.squashfs-4k)
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef