aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles/tp-link.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-08 12:46:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-08 12:46:25 +0000
commitb12d752a63e94e1072f9434edbae8cdc1ad8860e (patch)
tree02706f331633e59c51b621bd4f2a6992931b7b9d /target/linux/ar71xx/profiles/tp-link.mk
parent63d8f159dbe18944df5da24d09d2aee78a88612c (diff)
downloadupstream-b12d752a63e94e1072f9434edbae8cdc1ad8860e.tar.gz
upstream-b12d752a63e94e1072f9434edbae8cdc1ad8860e.tar.bz2
upstream-b12d752a63e94e1072f9434edbae8cdc1ad8860e.zip
ar71xx: preliminary support for the TL-WR1043ND
Adds board support for the TP-Link TL-WR1043ND Based on the Atheros AP81 platform. Presently the RTL8366RB switch support is missing due to no driver. The ethernet works with 5 ports@1Gbit but is missing vlan support. Hope Ive done this right, First time submiting a patch. Signed-off-by: Andrew Tarabaras <andrew@advancedtechnologies.com.au> SVN-Revision: 18696
Diffstat (limited to 'target/linux/ar71xx/profiles/tp-link.mk')
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
index ab5ed54ca5..d62ab8a7c6 100644
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -47,3 +47,14 @@ define Profile/TLWR941NDV2/Description
endef
$(eval $(call Profile,TLWR941NDV2))
+
+define Profile/TLWR1043NDV1
+ NAME:=TP-LINK TL-WR1043ND v1
+ PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/TLWR1043NDV1/Description
+ Package set optimized for the TP-LINK TL-WR1043ND v1.
+endef
+
+$(eval $(call Profile,TLWR1043NDV1))