aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-08 21:46:15 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-12 10:22:18 +0100
commit441ee62931140bd0672dd87e084a3606962db45c (patch)
tree0b9bc3fc2eea3eadc13eed9b9d608616b22ec5d3 /target/linux/ar71xx/patches-4.4
parentfa04682f213f81840ca17022ca5aa9439bc22f2c (diff)
downloadupstream-441ee62931140bd0672dd87e084a3606962db45c.tar.gz
upstream-441ee62931140bd0672dd87e084a3606962db45c.tar.bz2
upstream-441ee62931140bd0672dd87e084a3606962db45c.zip
ar71xx: remove AP83 reference design board support
This board is very old and unlikely to still be relevant today. Support for it contains a significant amount of device specific baggage which is worth getting rid of. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ar71xx/patches-4.4')
-rw-r--r--target/linux/ar71xx/patches-4.4/434-spi-ap83_spi_controller.patch27
-rw-r--r--target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch4
-rw-r--r--target/linux/ar71xx/patches-4.4/615-MIPS-ath79-ap83-remove-mtd-partitions.patch44
3 files changed, 2 insertions, 73 deletions
diff --git a/target/linux/ar71xx/patches-4.4/434-spi-ap83_spi_controller.patch b/target/linux/ar71xx/patches-4.4/434-spi-ap83_spi_controller.patch
deleted file mode 100644
index a67e8084a2..0000000000
--- a/target/linux/ar71xx/patches-4.4/434-spi-ap83_spi_controller.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
- # SPI master controller drivers (bus)
- obj-$(CONFIG_SPI_ALTERA) += spi-altera.o
- obj-$(CONFIG_SPI_ATMEL) += spi-atmel.o
-+obj-$(CONFIG_SPI_AP83) += spi-ap83.o
- obj-$(CONFIG_SPI_ATH79) += spi-ath79.o
- obj-$(CONFIG_SPI_AU1550) += spi-au1550.o
- obj-$(CONFIG_SPI_BCM2835) += spi-bcm2835.o
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -59,6 +59,14 @@ config SPI_ALTERA
- help
- This is the driver for the Altera SPI Controller.
-
-+config SPI_AP83
-+ tristate "Atheros AP83 specific SPI Controller"
-+ depends on SPI_MASTER && ATH79_MACH_AP83
-+ select SPI_BITBANG
-+ help
-+ This is a specific SPI controller driver for the Atheros AP83
-+ reference board.
-+
- config SPI_ATH79
- tristate "Atheros AR71XX/AR724X/AR913X SPI controller driver"
- depends on ATH79 && GPIOLIB
diff --git a/target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch b/target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch
index 78318f8e25..880c088c56 100644
--- a/target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch
+++ b/target/linux/ar71xx/patches-4.4/435-spi-vsc7385_driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -728,6 +728,11 @@ config SPI_RB4XX_CPLD
+@@ -720,6 +720,11 @@ config SPI_RB4XX_CPLD
SPI driver for the Xilinx CPLD chip present on the
MikroTik RB4xx boards.
@@ -14,7 +14,7 @@
#
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -92,6 +92,7 @@ obj-$(CONFIG_SPI_TEGRA20_SLINK) += spi-
+@@ -91,6 +91,7 @@ obj-$(CONFIG_SPI_TEGRA20_SLINK) += spi-
obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
diff --git a/target/linux/ar71xx/patches-4.4/615-MIPS-ath79-ap83-remove-mtd-partitions.patch b/target/linux/ar71xx/patches-4.4/615-MIPS-ath79-ap83-remove-mtd-partitions.patch
deleted file mode 100644
index 60872ae0a6..0000000000
--- a/target/linux/ar71xx/patches-4.4/615-MIPS-ath79-ap83-remove-mtd-partitions.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/arch/mips/ath79/mach-ap83.c
-+++ b/arch/mips/ath79/mach-ap83.c
-@@ -42,41 +42,8 @@
- #define AP83_KEYS_POLL_INTERVAL 20 /* msecs */
- #define AP83_KEYS_DEBOUNCE_INTERVAL (3 * AP83_KEYS_POLL_INTERVAL)
-
--static struct mtd_partition ap83_flash_partitions[] = {
-- {
-- .name = "u-boot",
-- .offset = 0,
-- .size = 0x040000,
-- .mask_flags = MTD_WRITEABLE,
-- }, {
-- .name = "u-boot-env",
-- .offset = 0x040000,
-- .size = 0x020000,
-- .mask_flags = MTD_WRITEABLE,
-- }, {
-- .name = "kernel",
-- .offset = 0x060000,
-- .size = 0x140000,
-- }, {
-- .name = "rootfs",
-- .offset = 0x1a0000,
-- .size = 0x650000,
-- }, {
-- .name = "art",
-- .offset = 0x7f0000,
-- .size = 0x010000,
-- .mask_flags = MTD_WRITEABLE,
-- }, {
-- .name = "firmware",
-- .offset = 0x060000,
-- .size = 0x790000,
-- }
--};
--
- static struct physmap_flash_data ap83_flash_data = {
- .width = 2,
-- .parts = ap83_flash_partitions,
-- .nr_parts = ARRAY_SIZE(ap83_flash_partitions),
- };
-
- static struct resource ap83_flash_resources[] = {