aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4
diff options
context:
space:
mode:
authorSteffen Weinreich <steve@weinreich.org>2017-04-27 23:59:22 +0200
committerJohn Crispin <john@phrozen.org>2017-05-18 14:47:53 +0200
commit224e5f5efa22b8a0132522367afd3b22f05d53e1 (patch)
tree6d53ab6c220b03aef69a0700ccf6c9d7133d64a7 /target/linux/ar71xx/patches-4.4
parentec987e59c4a4c5bbf65e6e667fb13853270d58ae (diff)
downloadupstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.tar.gz
upstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.tar.bz2
upstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.zip
ar71xx: Add support for Teltonika RUT900
Teltonika RUT900 is a Router with LTE dual SIM, WiFi, 4x Ethernet ports, I/O, RS232, RS485, GPS. The device ist based on a Atheros AR9344 rev 3, Specifications: - 560/450/225 MHz (CPU/DDR/AHB) - 128 MB of RAM - 16 MB of FLASH - Serial Console header on a Card Board edge connector - 4x 10/100 Mbps Ethernet (3x LAN, 1x WAN) - 2.4 GHz Wifi - 2x external, detachable Wifi antennas - LTE Modem Huawei ME909u-521 (Also other Modem seen) - 2x LTE antennas - 1x GPS antenna - 7x LED, 1x button - 1x USB Connector - 1x Serial RS232 - 1x Serial RS485 - 1x MicroSD Card The GPL sources of the device are available at www.teltonika.lt/gpl/ and are based on OpenWRT Barrier Breaker (14.07) Running from tftp: The Router starts into the uboot Webupdater if the Button ist pressed more than 3 seconds, if no Network cable is attached it starts the uboot serial console, from there the router loads the firmware image via tftpboot from 192.168.1.2:firmware.bin (the router has the 192.168.1.1). With bootm the loaded image will be booted. Signed-off-by: Steffen Weinreich <steve@weinreich.org>
Diffstat (limited to 'target/linux/ar71xx/patches-4.4')
-rw-r--r--target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch b/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch
new file mode 100644
index 0000000000..da4e088471
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -202,6 +202,12 @@ config MTD_TPLINK_PARTS
+ ---help---
+ TBD.
+
++config MTD_TLT_PARTS
++ tristate "Teltonika RUT900 partitioning support"
++ depends on ATH79
++ ---help---
++ Teltonika RUT900 partitioning support
++
+ comment "User Modules And Translation Layers"
+
+ #
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
+ obj-$(CONFIG_MTD_CYBERTAN_PARTS) += cybertan_part.o
++obj-$(CONFIG_MTD_TLT_PARTS) += tltpart.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o