aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-30 13:19:53 +0000
commit2530640f07cd2b3b14fe9ec03fa63a586452cc5f (patch)
treeda4d0e63a6771cbd044d3ba8d8dc97bd0615920f /target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch
parente5b5cce442f6fdaccf86064657518a5d0404f78e (diff)
downloadupstream-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.gz
upstream-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.tar.bz2
upstream-2530640f07cd2b3b14fe9ec03fa63a586452cc5f.zip
ar71xx: add support for linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48563
Diffstat (limited to 'target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch b/target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch
new file mode 100644
index 0000000000..cfcd07a193
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/413-mtd-ar934x-nand-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/nand/Kconfig
++++ b/drivers/mtd/nand/Kconfig
+@@ -554,4 +554,12 @@ config MTD_NAND_RB750
+ tristate "NAND flash driver for the RouterBoard 750"
+ depends on MTD_NAND && ATH79_MACH_RB750
+
++config MTD_NAND_AR934X
++ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
++ depends on (SOC_AR934X || SOC_QCA955X)
++
++config MTD_NAND_AR934X_HW_ECC
++ bool "Hardware ECC support for the AR934X NAND Controller (EXPERIMENTAL)"
++ depends on MTD_NAND_AR934X
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/Makefile
++++ b/drivers/mtd/nand/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-
+ obj-$(CONFIG_MTD_NAND_DENALI) += denali.o
+ obj-$(CONFIG_MTD_NAND_DENALI_PCI) += denali_pci.o
+ obj-$(CONFIG_MTD_NAND_DENALI_DT) += denali_dt.o
++obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nfc.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o
+ obj-$(CONFIG_MTD_NAND_BF5XX) += bf5xx_nand.o
+ obj-$(CONFIG_MTD_NAND_S3C2410) += s3c2410.o