aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-11-10 23:13:09 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-11-10 23:13:09 +0000
commitfa137d51f5cbc678922950a6b06883c1d2141ac2 (patch)
tree410f5ff10ecb345af68628cf3e09703b624ea41e /target/linux/ar71xx/patches-4.1
parent1bfbf2de6df94a5e62f690bec9999702e3ad4c81 (diff)
downloadupstream-fa137d51f5cbc678922950a6b06883c1d2141ac2.tar.gz
upstream-fa137d51f5cbc678922950a6b06883c1d2141ac2.tar.bz2
upstream-fa137d51f5cbc678922950a6b06883c1d2141ac2.zip
ar71xx: add Arduino Yun
This is based on patches from Federico Fissore <f.fissore@arduino.cc> especially this one: https://github.com/arduino/openwrt-yun/commit/7e2976fa83fb0d72a955574499178c387a1b3c92 The console is running with 250000 baud which is a non standard baud rate and needs an extra patch to be applied, I will try to get this patch upstream or something else which accomplish the same. Some upstream code looks like there are many different versions of this SoC, are these only internal versions and all versions on the consumer market are the same? I saw different GPIO configuration and flash sizes of 8MB and 16MB? Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47451
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch b/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch
new file mode 100644
index 0000000000..70073109f4
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch
@@ -0,0 +1,42 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -76,6 +76,19 @@ config ATH79_MACH_ANTMINER_S3
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_ARDUINO_YUN
++ bool "Arduino Yun"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++ help
++ Say 'Y' here if you want your kernel to support the
++ Arduino Yun.
++
+ config ATH79_MACH_AP113
+ bool "Atheros AP113 board support"
+ select SOC_AR724X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -23,6 +23,7 @@ enum ath79_mach_type {
+ ATH79_MACH_ALL0315N, /* Allnet ALL0315N */
+ ATH79_MACH_ANTMINER_S1, /* Antminer S1 */
+ ATH79_MACH_ANTMINER_S3, /* Antminer S3 */
++ ATH79_MACH_ARDUINO_YUN, /* Yun */
+ ATH79_MACH_AP113, /* Atheros AP113 reference board */
+ ATH79_MACH_AP121, /* Atheros AP121 reference board */
+ ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_ATH79_MACH_ALL0258N) += mac
+ obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
+ obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)+= mach-antminer-s1.o
+ obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)+= mach-antminer-s3.o
++obj-$(CONFIG_ATH79_MACH_ARDUINO_YUN) += mach-arduino-yun.o
+ obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
+ obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
+ obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o