aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.3
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-09-09 14:05:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-09-09 14:05:22 +0000
commit9b0f8cd2506e65aa8be8a2024b5e21f4ee97b6e2 (patch)
treeaf5c98cbbe52901212ff7a517c43198de32a8282 /target/linux/ar71xx/patches-3.3
parent26e1a6b953837dd78ba98204fb7668bd9e5b496e (diff)
downloadupstream-9b0f8cd2506e65aa8be8a2024b5e21f4ee97b6e2.tar.gz
upstream-9b0f8cd2506e65aa8be8a2024b5e21f4ee97b6e2.tar.bz2
upstream-9b0f8cd2506e65aa8be8a2024b5e21f4ee97b6e2.zip
ar71xx: add preliminary support for Mikrotik RB2011L
This patch adds preliminary support for the Mikrotik RB2011L. The NAND flash is not yet supported, so only the initramfs kernel can be used for now. [juhosg: remove unnecessary PCI/USB related stuff, the board does not use that, update commit message] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33344 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.3')
-rw-r--r--target/linux/ar71xx/patches-3.3/613-RB2011-support.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.3/613-RB2011-support.patch b/target/linux/ar71xx/patches-3.3/613-RB2011-support.patch
new file mode 100644
index 0000000000..ee16710306
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.3/613-RB2011-support.patch
@@ -0,0 +1,50 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -333,6 +333,11 @@ config ATH79_MACH_RB750
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_USB
+
++config ATH79_MACH_RB2011
++ bool "MikroTik RouterBOARD 2011 support"
++ select SOC_AR934x
++ select ATH79_DEV_ETH
++
+ config ATH79_MACH_WNDR3700
+ bool "NETGEAR WNDR3700 board support"
+ select SOC_AR71XX
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -61,6 +61,7 @@ enum ath79_mach_type {
+ ATH79_MACH_RB_750G_R3, /* MikroTik RouterBOARD 750GL */
+ ATH79_MACH_RB_751, /* MikroTik RouterBOARD 751 */
+ ATH79_MACH_RB_751G, /* Mikrotik RouterBOARD 751G */
++ ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
+ ATH79_MACH_RW2458N, /* Redwave RW2458N */
+ ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+ ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
+Index: linux-3.3.8/arch/mips/ath79/Makefile
+===================================================================
+--- linux-3.3.8.orig/arch/mips/ath79/Makefile
++++ linux-3.3.8/arch/mips/ath79/Makefile
+@@ -65,6 +65,7 @@ obj-$(CONFIG_ATH79_MACH_PB44) += mach-p
+ obj-$(CONFIG_ATH79_MACH_PB92) += mach-pb92.o
+ obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
+ obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
++obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
+ obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
+ obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
+ obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
+Index: linux-3.3.8/arch/mips/ath79/prom.c
+===================================================================
+--- linux-3.3.8.orig/arch/mips/ath79/prom.c
++++ linux-3.3.8/arch/mips/ath79/prom.c
+@@ -181,7 +181,8 @@ void __init prom_init(void)
+ }
+ }
+
+- if (strstr(arcs_cmdline, "board=750Gr3"))
++ if (strstr(arcs_cmdline, "board=750Gr3") ||
++ strstr(arcs_cmdline, "board=2011L"))
+ ath79_prom_append_cmdline("console", "ttyS0,115200");
+ }
+