aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-10 11:53:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-10 11:53:56 +0000
commit1b97bcd3dcb81fd277045a4fe590789e74e59682 (patch)
tree2f4a046c54773ff59de670c3e3c682d11b04d3f6 /target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch
parent6b23efb73330597680d55276039960ac99ffa53a (diff)
downloadupstream-1b97bcd3dcb81fd277045a4fe590789e74e59682.tar.gz
upstream-1b97bcd3dcb81fd277045a4fe590789e74e59682.tar.bz2
upstream-1b97bcd3dcb81fd277045a4fe590789e74e59682.zip
ar71xx: add preliminary support for 3.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30410 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..6cfe2e832e
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.3/432-spi-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -288,6 +288,12 @@ config SPI_PXA2XX
+ config SPI_PXA2XX_PCI
+ def_bool SPI_PXA2XX && X86_32 && PCI
+
++config SPI_RB4XX
++ tristate "Mikrotik RB4XX SPI master"
++ depends on SPI_MASTER && ATH79_MACH_RB4XX
++ help
++ SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ tristate "Samsung S3C24XX series SPI"
+ depends on ARCH_S3C2410 && EXPERIMENTAL
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_SPI_PL022) += spi-pl022.o
+ obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.o
+ obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
++obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
+ obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
+ spi-s3c24xx-hw-y := spi-s3c24xx.o
+ spi-s3c24xx-hw-$(CONFIG_SPI_S3C24XX_FIQ) += spi-s3c24xx-fiq.o