aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:49 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:49 +0000
commit71c67e149c08cf388576dbf00dda10dfba216d07 (patch)
treed3ecae2cbb4aa453c52f3bc3d1a06f9551f88f30 /target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
parent9098797092f663002173287fdafefbd7480aeb87 (diff)
downloadupstream-71c67e149c08cf388576dbf00dda10dfba216d07.tar.gz
upstream-71c67e149c08cf388576dbf00dda10dfba216d07.tar.bz2
upstream-71c67e149c08cf388576dbf00dda10dfba216d07.zip
ar71xx: Add TP-Link TL-WA901ND v4 support to Chaos Calmer 15.05.1
This patch backports support for the TP-Link TL-WA901ND v4 to Chaos Calmer 15.05.1, which was added into trunk recently [1]. Signed-off by Stijn Segers <francesco.borromini@inventati.org> [1]: http://patchwork.ozlabs.org/patch/606780/ git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49226 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch b/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
new file mode 100644
index 0000000000..ebd9e52e19
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/907-MIPS-ath79-add-tl-wa901nd-v4-support.patch
@@ -0,0 +1,38 @@
+--- a/arch/mips/ath79/machtypes.h 2016-04-12 21:08:09.309541276 +0200
++++ b/arch/mips/ath79/machtypes.h 2016-04-12 21:08:43.200013377 +0200
+@@ -152,6 +152,7 @@
+ ATH79_MACH_TL_WA901ND, /* TP-LINK TL-WA901ND */
+ ATH79_MACH_TL_WA901ND_V2, /* TP-LINK TL-WA901ND v2 */
+ ATH79_MACH_TL_WA901ND_V3, /* TP-LINK TL-WA901ND v3 */
++ ATH79_MACH_TL_WA901ND_V4, /* TP-LINK TL-WA901ND v4 */
+ ATH79_MACH_TL_WDR3500, /* TP-LINK TL-WDR3500 */
+ ATH79_MACH_TL_WDR4300, /* TP-LINK TL-WDR4300 */
+ ATH79_MACH_TL_WDR4900_V2, /* TP-LINK TL-WDR4900 v2 */
+--- a/arch/mips/ath79/Kconfig 2016-04-12 21:00:07.267269819 +0200
++++ b/arch/mips/ath79/Kconfig 2016-04-12 21:00:08.803199911 +0200
+@@ -1023,6 +1023,15 @@
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_TL_WA901ND_V4
++ bool "TP-LINK TL-WA901ND v4 support"
++ select SOC_QCA956X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WDR3500
+ bool "TP-LINK TL-WDR3500 board support"
+ select SOC_AR934X
+--- a/arch/mips/ath79/Makefile 2016-04-12 21:03:21.974455904 +0200
++++ b/arch/mips/ath79/Makefile 2016-04-12 21:02:56.115621524 +0200
+@@ -128,6 +128,7 @@
+ obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2) += mach-tl-wa830re-v2.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2) += mach-tl-wa901nd-v2.o
++obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V4) += mach-tl-wa901nd-v4.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR3500) += mach-tl-wdr3500.o
+ obj-$(CONFIG_ATH79_MACH_TL_WDR4300) += mach-tl-wdr4300.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR741ND) += mach-tl-wr741nd.o