aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
commit1cbb93865ed30fc4b23c3bf4a7839f170fafe46a (patch)
tree25160900b3ab73b5d01bbaf063c57c8a4e16b11c /target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
parentfebf61a29a25e83ffbf3546dd385422ec9303e88 (diff)
downloadupstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.gz
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.bz2
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch b/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
new file mode 100644
index 0000000000..15196bba98
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/906-MIPS-ath79-add-blackswift.patch
@@ -0,0 +1,45 @@
+Index: linux-3.18.19/arch/mips/ath79/Kconfig
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/Kconfig 2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/Kconfig 2015-08-10 17:08:03.195320098 +0100
+@@ -866,6 +866,16 @@
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_BSB
++ bool "Smart Electronics Black Swift board"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_ARCHER_C7
+ bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
+ select SOC_QCA955X
+Index: linux-3.18.19/arch/mips/ath79/Makefile
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/Makefile 2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/Makefile 2015-08-10 17:08:03.195320098 +0100
+@@ -54,6 +54,7 @@
+ obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += mach-archer-c7.o
+ obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
++obj-$(CONFIG_ATH79_MACH_BSB) += mach-bsb.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
+ obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
+Index: linux-3.18.19/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-3.18.19.orig/arch/mips/ath79/machtypes.h 2015-08-10 17:08:03.191320098 +0100
++++ linux-3.18.19/arch/mips/ath79/machtypes.h 2015-08-10 17:10:41.455317386 +0100
+@@ -37,6 +37,7 @@
+ ATH79_MACH_ARCHER_C7, /* TP-LINK Archer C7 board */
+ ATH79_MACH_AW_NR580, /* AzureWave AW-NR580 */
+ ATH79_MACH_BHU_BXU2000N2_A1, /* BHU BXU2000n-2 A1 */
++ ATH79_MACH_BSB, /* Smart Electronics Black Swift board */
+ ATH79_MACH_CAP4200AG, /* Senao CAP4200AG */
+ ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
+ ATH79_MACH_CPE510, /* TP-LINK CPE510 */