aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2016-10-25 22:58:12 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-10-25 22:58:12 +0200
commit2c54d989b46284bc5ee5b43d4ba7c2762c2241ed (patch)
tree1da1495f9fc9f046a169fb451ea5e6af13cc6453 /target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
parent2aefb514a4852f4c427b467150bbc7cdfe024528 (diff)
downloadupstream-2c54d989b46284bc5ee5b43d4ba7c2762c2241ed.tar.gz
upstream-2c54d989b46284bc5ee5b43d4ba7c2762c2241ed.tar.bz2
upstream-2c54d989b46284bc5ee5b43d4ba7c2762c2241ed.zip
CC: generic: bump kernel to 3.18.44
Patch 610- is updated as check_entry helper was killed in 3.18.37 Fixes CVE-2016-5195 (dirtycow) Compile-tested on ar71xx, mxs, sunxi, imx6 Runtime-tested on ar71xx (PB42) Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch b/target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
index 4accd030be..4eea429e55 100644
--- a/target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
+++ b/target/linux/ar71xx/patches-3.18/815-MIPS-ath79-add-om5pac-support.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -799,6 +799,15 @@ config ATH79_MACH_OM5P
+@@ -779,6 +779,15 @@ config ATH79_MACH_OM5P
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
@@ -18,7 +18,7 @@
select SOC_AR933X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += m
+@@ -97,6 +97,7 @@ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += m
obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
obj-$(CONFIG_ATH79_MACH_OM2P) += mach-om2p.o
obj-$(CONFIG_ATH79_MACH_OM5P) += mach-om5p.o
@@ -28,7 +28,7 @@
obj-$(CONFIG_ATH79_MACH_PB44) += mach-pb44.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -95,6 +95,7 @@ enum ath79_mach_type {
+@@ -92,6 +92,7 @@ enum ath79_mach_type {
ATH79_MACH_OM2P_LC, /* OpenMesh OM2P-LC */
ATH79_MACH_OM2Pv2, /* OpenMesh OM2Pv2 */
ATH79_MACH_OM2P, /* OpenMesh OM2P */