aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-04-20 20:47:48 +0000
committerLuka Perkov <luka@openwrt.org>2015-04-20 20:47:48 +0000
commit68c954eb574aadddfb9c8fbeacdc54fed893d8b6 (patch)
tree030b7b9022bfdca238d5efd70de2beddae109a85 /target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
parent204e157668a940fabbcfba928a4decd556942898 (diff)
downloadupstream-68c954eb574aadddfb9c8fbeacdc54fed893d8b6.tar.gz
upstream-68c954eb574aadddfb9c8fbeacdc54fed893d8b6.tar.bz2
upstream-68c954eb574aadddfb9c8fbeacdc54fed893d8b6.zip
ar71xx: add support for compex wpj344
Signed-off-by: Christian Mehlis <christian@m3hlis.de> Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45527 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch26
1 files changed, 19 insertions, 7 deletions
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index 2aca064eee..5e07d80511 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,190 @@
+@@ -16,22 +16,191 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -178,6 +178,7 @@
+ ATH79_MACH_WNR1000_V2, /* NETGEAR WNR1000 v2 */
+ ATH79_MACH_WP543, /* Compex WP543 */
+ ATH79_MACH_WPE72, /* Compex WPE72 */
++ ATH79_MACH_WPJ344, /* Compex WPJ344 */
+ ATH79_MACH_WPJ558, /* Compex WPJ558 */
+ ATH79_MACH_WRT160NL, /* Linksys WRT160NL */
+ ATH79_MACH_WRT400N, /* Linksys WRT400N */
@@ -264,7 +265,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +75,976 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,986 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -499,6 +500,16 @@
+ select ATH79_DEV_USB
+ select MYLOADER
+
++config ATH79_MACH_WPJ344
++ bool "Compex WPJ344 board support"
++ select SOC_AS934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_WPJ558
+ bool "Compex WPJ558 board support"
+ select SOC_QCA955X
@@ -1269,7 +1280,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1061,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1071,97 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -1367,7 +1378,7 @@
endmenu
config SOC_AR71XX
-@@ -124,7 +1193,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1203,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1379,7 +1390,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -154,6 +1226,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -154,6 +1236,11 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
config ATH79_ROUTERBOOT
@@ -1393,7 +1404,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,119 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +48,120 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1502,7 +1513,8 @@
+obj-$(CONFIG_ATH79_MACH_WNR2200) += mach-wnr2200.o
+obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
+obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
-+obj-$(CONFIG_ATH79_MACH_WPJ558) += mach-wpj558.o
++obj-$(CONFIG_ATH79_MACH_WPJ344) += mach-wpj344.o
++obj-$(CONFIG_ATH79_MACH_WPJ558) += mach-wpj558.o
+obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o
+obj-$(CONFIG_ATH79_MACH_WRT400N) += mach-wrt400n.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH) += mach-wzr-hp-g300nh.o