aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-24 12:00:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-24 12:00:50 +0000
commit48fe4e99f2336a9ab3d3d7220e52160e6bce776a (patch)
tree4c8d2425da1a52dfe457e99db29b1a13b8804d8a /target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
parent23193222d4c9d692bf4c73d7e4347f19637cb002 (diff)
downloadupstream-48fe4e99f2336a9ab3d3d7220e52160e6bce776a.tar.gz
upstream-48fe4e99f2336a9ab3d3d7220e52160e6bce776a.tar.bz2
upstream-48fe4e99f2336a9ab3d3d7220e52160e6bce776a.zip
ar71xx: TL-WA7210n v2 support
This patch adds support for TP-Link TL-WA7210n[0] [0] http://www.tplink.com/en/products/details/?model=TL-WA7210N Signed-off-by: Hendrik Frenzel <hfrenzel@scunc.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch18
1 files changed, 15 insertions, 3 deletions
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index ce839f4b01..832df9e6ca 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,188 @@
+@@ -16,22 +16,189 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -116,6 +116,7 @@
+ ATH79_MACH_TL_MR3420_V2, /* TP-LINK TL-MR3420 v2 */
+ ATH79_MACH_TL_WA701ND_V2, /* TP-LINK TL-WA701ND v2 */
+ ATH79_MACH_TL_WA750RE, /* TP-LINK TL-WA750RE */
++ ATH79_MACH_TL_WA7210N_V2, /* TP-LINK TL-WA7210N v2 */
+ ATH79_MACH_TL_WA7510N_V1, /* TP-LINK TL-WA7510N v1*/
+ ATH79_MACH_TL_WA850RE, /* TP-LINK TL-WA850RE */
+ ATH79_MACH_TL_WA860RE, /* TP-LINK TL-WA860RE */
@@ -262,7 +263,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +75,960 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,970 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -1006,6 +1007,16 @@
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
++
++config ATH79_MACH_TL_WA7210N_V2
++ bool "TP-LINK TL-WA7210N v2 support"
++ select SOC_AR724X
++ select ATH79_DEV_AP9X_PCI if PCI
++ select ATH79_DEV_ETH
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
-config ATH79_MACH_AP136
- bool "Atheros AP136/AP135 reference board"
@@ -1371,7 +1382,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,117 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,118 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1447,6 +1458,7 @@
+obj-$(CONFIG_ATH79_MACH_TL_MR3X20) += mach-tl-mr3x20.o
+obj-$(CONFIG_ATH79_MACH_TL_WAX50RE) += mach-tl-wax50re.o
+obj-$(CONFIG_ATH79_MACH_TL_WA701ND_V2) += mach-tl-wa701nd-v2.o
++obj-$(CONFIG_ATH79_MACH_TL_WA7210N_V2) += mach-tl-wa7210n-v2.o
+obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2) += mach-tl-wa830re-v2.o
+obj-$(CONFIG_ATH79_MACH_TL_WA901ND) += mach-tl-wa901nd.o
+obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2) += mach-tl-wa901nd-v2.o